Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all: I am well aware of the following the existing thread on UEFI, as well as the guide by Rod Smith, and I have read on the problem on various forums for maybe 10 hours (2 days), but could not find an answer to my question.

I want to install Ubuntu but I do NOT want to disable secure boot at any time during the installation process. Is this possible? I have an Acer Aspire V5-573G and Windows8.1 installed.

So far all my tries of even just launching a Live-Install from USB end in a black screen after choosing at the "Live- or full install to hdd" screen.

Not sure if I am allowed to ask this, but would it help to take any other Linux Distribution (Fedora)?

I never had a Linux installation running, so any solutions that need massive Linux knowlegde might not help me. I would still like to hear about them thou. :D Thx in advance.


Also, I am well aware of the bad reputation of secure boot, but please just accept my wish to keep it activated ALL the time. (Lets say my employer forces me to...)

share|improve this question
    
I wish to do the same thing with a HP envy desktop and get a black screen with just one under score on it. I also cannot find a soulution. I will submit a bug report. I went thru windows 8 boot cd/dvd sequence and have a ubuntu 13.10 dvd. also turned off fast boot. system inits because i see HP bios splash screen then the blank screen with just one underscore. trying to understand this link, my help us wiki.ubuntu.com/SecurityTeam/SecureBoot –  Bill Mar 2 at 22:49
add comment

1 Answer

Solved my problem by disabling fast boot in HP bios.

The following link confirmed it could be done.

After reading this article I went into HP bios (esc or F10) Security, Secure boot and Disabled Fast Boot.

My ubuntu 13.10 and fedora 20 live dvds would boot and install in efi / secure boot mode and reboot windows, ubuntu and fedora if I went into firmware boot (F9)

(actually worked booting to ubuntu grub then windows or ubuntu, but after installing fedora it would boot to fedora only unless I used F9 boot menu. Trying to learn efibootmgr to fix this problem)

Most of the tutorials mention disabling fast boot in windows under power options, but in my case I had to also disable it in the bios.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.