Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed gnome shell on my Ubuntu 11.04. It gave me an error about

E: /var/cache/apt/archives/gnome-session_3.0.1-0ubuntu1~build1_all.deb: trying to overwrite '/usr/share/gnome-session/sessions/gnome.session', which is also in package gnome-session-common 2.32.1-0ubuntu20

After a while with -f and stuff I managed to get gnome shell to work but the gtk theme looks very ugly. So I want to update and install the standard gnome theme and it gives me this error:

The following packages have unmet dependencies:

gnome-shell: Depends: libcamel1.2-19 (< 2.33) but 2.32.2-0ubuntu2 is installed
             Depends: libffi5 (>= 3.0.4) but 3.0.9-3ubuntu1 is installed
             Depends: libnspr4 (>= 4.7.0~1.9b1) but 4.8.7-0ubuntu1 is installed
             Depends: libnss3 (>= 3.12.2~rc1) but 3.12.9+ckbi-1.82-0ubuntu2 is installed
             Depends: libsqlite3-0 (>= 3.7.3) but 3.7.4-2ubuntu5 is installed
             Depends: libxfixes3 (>= 1:4.0.1) but 1:4.0.5-1ubuntu1 is installed
             Depends: gnome-themes-standard (>= 2.91) but it is not installed

What to do. I know it's really unstable and stuff but I have some bug with gnome 2 and gnome 3 behind all of this. At least, that's what I read out of it all. How to fix it? Thanks.

share|improve this question

closed as too localized by Marco Ceppi Jun 5 '11 at 22:11

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

I'm having the same problem. I'm getting: The following packages have unmet dependencies: gnome-shell : Depends: gnome-themes-standard (>= 2.91) but it is not installed when i'm trying to do dist-upgrade, or trying to install anything at all. – user16812 May 6 '11 at 23:31

Please do not use the Gnome 3 PPA. It is an EXPERIMENTAL, alpha, developer preview and you will almost certainly have various problems.

share|improve this answer

run Synaptic Package Manager and remove the package called "gnome-accessibility-themes" then install "gnome-themes-standard"

That worked for me. I think there is some conflicting dependency somewhere in those packages.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.