Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I asked this question on the Electronic Engineering StackExchange but could not find the right answer and the question was closed as it was flagged unrelated.

I am trying to install the latest version of the Libero SW tools set from Microsemi/Actel on my Ubuntu laptop.

The web site of the company says that their SW only supports the RH linux and they don't mention Ubuntu anywhere on their site. But I only have access to Ubuntu and therefore need to find a way to install it so I can work on my project.

I have followed the instruction of Microsemi and installed all the necessary libraries before running the installation program, but I still can't get this to work.

Does anyone knows if SW for RH can be installed on Ubuntu? Do I need to add extra libraries that are not part of current installation I have?

My installation is "Linux 3.8.0.32-generic x86_64"

Thanks in advance for your help.

First I could not install it at all, but after I installed some fonts as I found from the following line, I got a bit further and got the following error message:

Preparing to install... Extracting the JRE from the installer archive... Unpacking the JRE... Extracting the installation resources from the installer archive... Configuring the installer for this system's environment... strings: '/lib/libc.so.6': No such file

Launching installer...

Graphical installers are not supported by the VM. The console mode will be used instead...

Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX) /lib/libc.so.6

After I searched for it I found it under multiple locations on my installation

sudo find / -name "libc.so.6"

/lib/x86_64-linux-gnu/libc.so.6

/lib/i386-linux-gnu/libc.so.6

/lib32/libc.so.6

and then created a link to fix that:

sudo ln -s /lib/i386-linux-gnu/libc.so.6 /lib/libc.so.6

Now I am going further in the installation, but it still not evne starting the installation! This is the last error I am getting:

Launching installer...

Graphical installers are not supported by the VM. The console mode will be used instead...

Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

Stack Trace: java.lang.UnsatisfiedLinkError: /tmp/install.dir.10759/Linux/resource/jre/lib/i386/xawt/libmawt.so: libXtst.so.6: cannot open shared object file: No such file or directory

I am not an expert on Linux, even thought I have pretty good basic knowledge but this is really stopping me from moving forward.

Really appreciate your help.

share|improve this question

1 Answer 1

I think i managed to get a clean installation without too much tweaking. Please see the help page on LiberoSOC.

Hope it helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.