Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm recently installed Ubuntu 13.10 on my PC and it was working fine. However, I was messing around with Conky (the system resource monitor) and was having some issues. I did a little research and someone said that it had to with nVidia drivers not being installed. So I installed the drivers and restarted the computer. However, I was presented with a black screen and my cursor after logging in. Once again, I researched this and ended up going to tty1 and typing in

sudo apt-get --purge remove nvidia-*

This worked as far as allowing me to access the Unity interface and be able to use Ubuntu, however now the only resolution my computer is using is 800x600. It used to be 1920x1080 before this whole fiasco. I tried modifying the xorg.conf file but nothing happened. This is the (modified) xorg.conf file I currently have

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 331.38  (buildmeister@swio-display-x64-rhel04-12)  Wed Jan  8 19:59:52 PST 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
SubSection     "Display"
    Viewport    0 0
    Depth       24
    Modes       "1920x1080"
    EndSubSection
EndSection

The part I modified is the "Display" subsection. It used to only have the Depth 24 line but after reading a little, others said adding those extra lines worked for them. Also, when replying, please don't assume I have any Linux/Ubuntu knowledge because this is the first time I'm using Linux.

Thanks!

Edit: I figured posting the output of xrandr may help:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 800 x 600, maximum 800 x 600
default connected primary 800x600+0+0 0mm x 0mm
   800x600         0.0* 
   640x480        60.0

Edit 2: Also, here's the output of lspci|grep VGA:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

It says that it only finds my Intel card, but I have a NVidia GT740M as well.

share|improve this question
    
The xorg.conf file is still referencing the nvidia driver. Move it somewhere else (eg sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.nvidia) and reboot, as I don't think you really necessarily need it these days. –  Ash Jan 19 at 5:44
    
@Ash - You are a lifesaver! This worked. Not sure why, but it worked. If you don't mind, can you post this as an answer so I can mark it as correct? Thanks again :D Also, is it possible for me to have nvidia drivers too or are those gone? –  Globmont Jan 19 at 5:48
    
Good to hear Globmont! Answer added -- I'll include how I install nvidia drivers if you like. The nVidia GPU should be listed somewhere in the output of lspci. –  Ash Jan 19 at 8:51
add comment

1 Answer

up vote 1 down vote accepted

Since the xorg.conf was referencing the nVidia driver, I suspect the system was getting confused. Removing that conf file should allow the regular driver (nouveau I guess) to fall back to default settings.

To keep the existing file for later reference, suggested method was to rename:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.nvidia

If you want to reinstall the nVidia drivers, this is the install process I use:

sudo apt-get install nvidia-current
sudo nvidia-xconfig

And reboot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.