Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have never used a linux distribution before in my life.

After downloading Ubuntu 13.10 because it is the only one compatible with my motherboards onboard lan, I wanted to install the drivers for my gtx 760. I downloaded them directly from the Nvidia site. Upon rebooting Ubuntu would not load the desktop and would only display that it wanted to load low graphics mode.

I have tried each solution in this thread: How to fix "The system is running in low-graphics mode" error? and none worked.

I have tried multiple other methods for installing my drivers, all of which claim to be the proper way and none work, all cause the same error.

I am now in a fresh working install of ubuntu with no other operating systems on this machine, if someone could step by step tell me how to install my drivers that would be much appreciated.

As a side note, this is not the only problem I have encountered, my R.A.T 3 gaming mouse also does not work with ubuntu and causes a similar error as what happens with my video drivers when I try to implement the fixes I have found for it. These issues are very discouraging and if I don't figure them out soon I believe I will switch back to windows.

share|improve this question
add comment

1 Answer

OK, I'm no expert, but these are the steps that worked for me and my Nvidia drivers. I'm using 12.04, but the process should be pretty much the same. I used this page , but modified the instructions a bit.

1)Install the latest Linux headers with

sudo apt-get install build-essential linux-headers-`uname -r`  

For me, those headers gave me problems, so I used 3.4.0-030400-generic instead of uname -r. Just make sure to use Synaptic to get rid of the ones you don't use.

2)For me, I completely uninstalled every other driver on the system instead of just disabling them. If you don't want to do that, follow the instructions on the page I linked.

3)Press Ctrl+Alt+F1 to get into text-only mode, or whatever you call it.

4) This is what differs from the guide I linked. I just used the command sudo lightdm stop and it worked fine.

5) Run the command sudo sh /name/of/directory/NVIDIA* depending on where you save the driver file. You can hit tab to auto-complete the name of the driver file. It will walk you through the installation.

6) Do a sudo reboot and you should be good to go!

share|improve this answer
    
I tried following those steps but I think I am missing a lot of stuff. How do I know what linux headers I don't use and should uninstall? A lot of the commands in the tutorial you linked didn't work at all. I am really lost, is there a version of teamviewer or anything for Ubuntu? –  user237083 Jan 19 at 4:41
    
Forget it, I can't even figure out how to get teamviewer to work without bugs. Is there an easier form of linux because this just makes me want to gouge my eyes out, the only thing to work so far after 3 days of trying is firefox. –  user237083 Jan 19 at 4:56
    
Oh, I'm really sorry for confusing you. This is a more complicated way to install drivers. I'll help you with this if you want, but first, have you tried going to System Settings>Additional Drivers, and then clicking on the reccomended driver, then hitting activate? These drivers should work just fine for most users. Do that, and then reboot. –  rcrobot Jan 19 at 5:01
    
Nobody told me about that, all I could find were lots of root commands to type. I dont see a reccomended one though, just Using NVIDIA binary Xorg driver, kernel module and VDPAU library from nvidia-319, Using X.Org X server -- Nouveau display driver from xserver-xorg-video-nouveau, and using NVIDIA binary Xorg driver, kernel module and VDPAU library from nvidia-319- updates (proprietary) –  user237083 Jan 19 at 5:08
    
You'll probably want to use the one that has says "nvidia-319". The one without the word "updates". That should work just fine. –  rcrobot Jan 19 at 5:16
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.