Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My frustration is that after selecting a window button on my panel (Xubuntu 12.04), if I don't move my cursor away from the window buttons and begin scrolling (intending to scroll the content within the window), the windows manager cycles through all of the open windows.

How do I disable the window button scrolling feature?

I have tried looked in Windows Manager Settings, Windows Manager Tweaks Settings, Panel Settings, Windows Button Settings and xfwm4 settings in the Settings Editor but couldn't find anything to change it.

Online, the closest thing I have found is this libwnck-noscroll ppa. Despite the fact that it said it was made for older distros, I tried it and it didn't work. Is anyone aware of another fix?

share|improve this question
add comment

2 Answers

Enable the ppa:xubuntu-dev/xfce-4.10 PPA and upgrade to Xfce 4.10. Then search for the handle to the left of the Window Buttons panel plug-in and right-click on it, then Properties, then disable "Switch windows using the mouse wheel".

share|improve this answer
add comment

This can be changed, but the toggle is really well hidden.

Right click on the panel, select "Panel" then "Panel Preferences".

enter image description here

Switch to the "Items" tab, select the "Window Buttons" item in the list and click the wrench icon.

enter image description here

Then uncheck "Switch windows using the mouse wheel"

enter image description here

You're done!

share|improve this answer
    
Thanks for your quick response! Yeah I had already looked there and for some reason I don't have the option there... yes I am jealous. Are you working from the same distro as me? Or do you think my xfwm4 could be out of date? –  jamin39 Jan 19 at 22:37
    
My version of xfwm4 is 4.8.3 and xfce4-panel is 0.1 it seems. –  jamin39 Jan 19 at 23:10
    
@jamin39 I'm not at my computer right now, but I forgot to mention that I'm running Saucy so I was probably using version 4.10.1... I will check then I get back. The option might not exist in your version :-/ –  Seth Jan 20 at 0:52
    
@jamin39 I have confirmed the option is only available in xfwm4 version 4.10. I think you might be able to upgrade xfwm without upgrading to 13.10, but I'm not sure as of yet. –  Seth Jan 21 at 20:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.