Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

after opening http 127.0.0.1 in the browser it displays info:

It works! This is the default web page for this server. The web server software is running but no content has been added, yet.

The point is I have added files to the DocumentRoot catalog

Things i changed: /etc/apache2/envvars

from

export APACHE_RUN_USER=www-data
export APACHE_RUN_GROUP=www-data

to

export APACHE_RUN_USER=chiny 
export APACHE_RUN_GROUP=chiny

file /etc/apache2/sites-enabled/000-default.conf looks:

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /home/chiny/Pulpit/lab


<Directory /home/chiny/Pulpit/lab/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Require all granted
    Allow from all
</Directory>

    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com



    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf


</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

my DocumentRoot where i have my html files

root@chiny-HP-Compaq-dc7100-CMT-DX438AV:/home/chiny/Pulpit/lab# ls -l /home/chiny/Pulpit/lab 
razem 60 
-rwxrwxr-x 1 chiny chiny 3096 sty 18  2013 10.html 
-rwxrwxr-x 1 chiny chiny 2562 sty 18  2013 11.html 
-rwxrwxr-x 1 chiny chiny 3010 sty 18  2013 12.html 
-rwxrwxr-x 1 chiny chiny 3045 sty 18  2013 1.html 
-rwxrwxr-x 1 chiny chiny 3016 sty 18  2013 2.html 
-rwxrwxr-x 1 chiny chiny 2772 sty 18  2013 3.html 
-rwxrwxr-x 1 chiny chiny 2814 sty 18  2013 4.html 
-rwxrwxr-x 1 chiny chiny 2638 sty 18  2013 5.html 
-rwxrwxr-x 1 chiny chiny 2794 sty 18  2013 6.html 
-rwxrwxr-x 1 chiny chiny 2722 sty 18  2013 7.html 
-rwxrwxr-x 1 chiny chiny 2591 sty 18  2013 8.html 
-rwxrwxr-x 1 chiny chiny 2620 sty 18  2013 9.html 
-rw-r--r-- 1 chiny chiny  177 sty 18 18:37 index.html 
-rwxrwxr-x 1 chiny chiny    0 sty 18 14:43 plik 
-rwxrwxr-x 1 chiny chiny 1711 sty 17  2013 styles.css 
-rwxrwxr-x 1 chiny chiny 3181 sty 17  2013 w3schoolslogo.gif 

also /home/chiny/Pulpit/lab is owned and group by chiny

drwxrwsr-x 2 chiny chiny  4096 sty 18 18:37 lab

nothing changed in apache2.conf

after restarting apache this info:

root@chiny-HP-Compaq-dc7100-CMT-DX438AV:/home/chiny/Pulpit# /etc/init.d/apache2 restart 
 * Restarting web server apache2                                                             AH00557: apache2: apr_sockaddr_info_get() failed for chiny-HP-Compaq-dc7100-CMT-DX438AV 
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message 
share|improve this question

2 Answers 2

Personally, I recommend reverting all of your changes to Apache configs, resetting server root to /var/www, and just putting all of your content there.

You can then easily chmod to 775, and add yourself to the www-data group by running command:

 sudo usermod -a -G www-data your_username
share|improve this answer
    
unfortunately that is one of the tasks in study laboratory. Share html file from created catalog. –  user233352 Jan 18 at 21:50
    
Symlink maybe? /dir/to/the/folder/lab -> /var/www/lab –  Mew Jan 18 at 21:52
    
it should work without these tricks –  user233352 Jan 18 at 22:07
up vote 0 down vote accepted

it appeared that index.html was a orginal file from var/www that i copied to my documentroot. and content of this file is exactly this message:"It works! This is the default web page for this server. The web server software is running but no content has been added, yet."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.