Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been messing around with my fairly new installation of Ubuntu 13.10 Gnome, where I installed two keyboard layouts - English (UK) and Russian. They worked well, I could switch them with the quirky Super+Space combination, but up until the point I tried to run Unity alongside Gnome. Mind you, it worked (kind of) - I got the Unity dock etc, but only on the root account.

But then I changed my mind. I didn't want Unity, after all. I uninstalled it by typing sudo apt-get remove --purge unity and sudo apt-get remove --purge ubuntu-desktop, which, as I have later found out, uninstalled Nautilus and other useful things. I had to do a lot of rebooting and reconfiguring (so much that I can't remember) to make things work again, and when I needed the Russian keyboard, I found out that I couldn't change to it. I can assure you, I have tried everything in the Keyboard Settings, and I followed a few Ask Ubuntu threads - here and here.

All of this didn't help me. I also tried editing the /etc/default/keyboard file, but that didn't help either. Now I'm stuck with the English default keyboard, even if I try to remove it through the Keyboard Settings GUI and change it to Russian, I still type in latin alphabet.

P.S. I later found out that changing keyboard layouts works if I login as root, and that changing the system language to Russian works too, but does not affect my keyboard setup.

share|improve this question
    
Try creating a new user? –  Sneetsher Jan 19 at 13:38
1  
So I've created a new user, and the keyboards are fine! Now, I'll have to think of a way of how to transfer all of my files and settings to that new user account... Thanks for the help! –  Nick Jan 19 at 14:01
1  
As a matter of fact, yes. But after clearing out my .cache and moving my .local and checking some other folders, I decided to stuff the idea, and move on to browse through my /usr/share/X11/ directory. Now reading this how-to... –  Nick Jan 20 at 16:59
1  
I made a breakthrough! Ш have loaded the Russian keyboard by doing setxkbmap -option grp:alt_shift_toggle ru, and and am now using Google Translate to write in latin alphabet, as I have forgot to add the us option when carrying out the command –  Nick Jan 20 at 17:17
1  
Yep, it's working now! I have found the answer to my long, heart aching quest! This answer helped me very much. –  Nick Jan 20 at 17:20
show 8 more comments

2 Answers 2

up vote 1 down vote accepted

After spending a very long day and a half trying to figure out why my keyboard layouts wouldn't switch from English (UK) to Russian on my main user account, I found the solution - I ran this command which I found on another askubuntu answer topic -

setxkbmap -option grp:alt_shift_toggle gb,ru

Where the gb and ru are the languages, and the alt_shift_toggle is the key combination to change the languages. However, because I have applied this sort of a hack, it means that the keyboard settings which I set via the GUI did not update and will remain in a "broken" state (at least that's how it is for me)...

Update: After logging out and logging back in, I found that my changes did not stay, and that I had to carry out that command again to be able to use both of the keyboard layouts...

share|improve this answer
add comment

Install TweakTool:

sudo apt-get install gnome-tweak-tool

Tweak Tool → Typing → Switching to another layout

share|improve this answer
1  
I have it, I tried everything, Tweak Tool doesn't change anything... I still don't know what happened there, after I uninstalled Unity. –  Nick Jan 19 at 13:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.