Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I restart (or shut down) Windows 8.1, it always corrupts the grub UEFI partition. Next time I boot, GRUB says:

  GRUB Loading stage1.5.

  GRUB loading, please wait...  Error 17

I have disabled in my BIOS QuickBoot/FastBoot, and FastStartup in my Win8.1 configuration, as mentioned here:

https://help.ubuntu.com/community/UEFI

My boot-repair report is in this link:

http://paste.ubuntu.com/6769635/

I have checked this thread (Windows 8.1 repeatedly corrupts GRUB UEFI boot manager) without any positive result for me.

Do you have any other ideas?

share|improve this question

1 Answer 1

I have not seen corruption like this on gpt. Usually the gpt tools do not let you do this. Overlap issues can be a real issue as you may have written data from both and then have corruption. best is to delete sda5 if possible and it has no data. But you may need chkdsk on NTFS and fsck on ext4 partitions afterwards. Best to have good backups before doing anything.

/dev/sda5 overlaps with /dev/sda7
/dev/sda5 overlaps with /dev/sda8
/dev/sda5 overlaps with /dev/sda9

And the errors you are getting are from booting in BIOS mode from sdb which has a very old grub legacy boot loader in the MBR. You only have UEFI installs, so should not be booting in BIOS mode.

Edit: Be very careful that drive is really still sdb, but since UEFI erasing sda should not matter. Zero out MBR only of sdb Use bs=440 if windows as serial number (BIOS only) is between 440 & 446.

dd if=/dev/zero of=/dev/sdb bs=446 count=1

see also this:

http://www.rodsbooks.com/gdisk/repairing.html

share|improve this answer
    
It has no sense... I think I could fix the overlaps issues on the sda gpt table (it's strange because this hd is running like this some months ago, with win so only). –  Luis Jan 18 at 19:15
    
But change the BIOS mode on booting from sdb to sda... I don't know how to fix this (I don't see anything wrong in the motherboard settings). I will try removing the boot information on sdb. –  Luis Jan 18 at 19:22
    
I do not know why your system would switch to a BIOS boot. It must be totally rebooting and you have sdb in BIOS mode as first in Boot order? I do not normally suggest dd, but will add it above so it is formatted better. –  oldfred Jan 18 at 20:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.