Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want when i maximized a window for the minimize,maximize and close buttons to not go left but stay right like in Ubuntu 10.10.

Thanks

share|improve this question
add comment

3 Answers

To clarify the question, I believe this relates to the Unity interface in Ubuntu 11.04. If the window controls are switched to the right of the screen, they function correctly when an application is running in a window. However, if the application is maximized, the window controls switch to the left side of the screen.

While this may be considered to be a bug, since the user has indicated a preference for the "normal" (i.e. historical) location of the window controls by changing the system configuration, it is apparently a designed-in feature, related to positioning the controls in the top panel.

See http://www.omgubuntu.co.uk/natty/panel where it is stated that "When you maximize an application, the window controls (Close, Minimize, Maximize) are moved into the panel to give you more vertical working space."

share|improve this answer
add comment

Here is the trick.

Press alt+f2.
Type gconf-editor.
Select apps/metacity/general
Look for button_layout and change the value in to this.
menu:minimize,maximize,close

The button will change right then and then from left to right. if it wont change try logging out.

$ sudo /etc/init.d/gdm restart

note: before colon (:) means the buttons are on left side and after colon (:) means the buttons are on the right side.

or if your still confuse visit this link http://www.cebuntu.com/how-to/changing-window-button-from-left-to-right/

share|improve this answer
    
Please note that this works in Lucid, but hopefully works with Natty. –  dsaint May 6 '11 at 16:50
    
The above method will not work on natty. It only works until 10.10. –  neo May 6 '11 at 17:28
    
thanks for ur answer ,i know this but i mean the buttons that go to left when u maximize in minimize its ok and its in right . –  Jwtiyar May 6 '11 at 18:17
add comment

This is clearly a bug in 11.04 with the unify desktop.

As it is specified by preferences that the user wishes the buttons on the right side, they also should be on the right side even if the window is maximized. There should be no influence with the feature, that the controls are positioned in the panel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.