Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install MATLAB and I am running into some issues with the installer program with Ubuntu 13.10.

I get to the screen which tells me to select the directory I wish to install in, I then select next and it tells me the folder does not exist and asks me if I wish to create a new one; if I select to create the folder it gives me the error:

Failed to create folder (/usr/local/MATLAB/R2013b/)

I then tried to create the folder manually; using sudo mkdir /usr/local/MATLAB/ and then sudo mkdir /usr/local/MATLAB/R2013b/, but the installation continues to fail with the same error.

Has anyone encountered and overcome this error before?

Thanks in advance!

share|improve this question
    
Did you run the MATLAB installer with root privileges? –  Avinash Raj Jan 18 at 15:06
    
@AvinashRaj I'm not sure, I ran it through the GUI rather than through terminal, so perhaps not? –  Shaktal Jan 18 at 15:07
    
Try to run the installer via terminal with sudo. –  Avinash Raj Jan 18 at 15:08
    
@AvinashRaj I can no longer find the installer; do you happen to know where it's usually stored after being downloaded? –  Shaktal Jan 18 at 15:10
    
@AvinashRaj Thank you very much! –  Shaktal Jan 18 at 15:15
show 1 more comment

2 Answers 2

Try to run the MATLAB installer via terminal using root privileges aka sudo.

  • Go into the MATLAB directory via terminal.

  • Change install file into an executable one by running

    sudo chmod +x install

  • Now run the installer ,

    sudo ./install

share|improve this answer
    
Still it shows /tmp/mathworks_2704/sys/java/jre/glnxa64/jre/bin/java: Permission denied –  binayak dutta Jan 21 at 4:39
    
if you had any problem with matlab then ask it as a question. –  Avinash Raj Jan 21 at 10:31
add comment

If you are getting Java problem while installing MATLAB that means you extracted MATLAB. I recommend you mount the .iso file in Archive Manager then browse to mount place and run

sudo ./install

This way you won't have this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.