Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I tried to open my bashrc and tried to provide an alias for eclipse like

alias eclipse='bash /usr/local/softy/eclipse/eclipse'

But I get the following error when I try to invoke eclipse.

/usr/local/softy/eclipse/eclipse: /usr/local/softy/eclipse/eclipse: cannot execute binary file

Its permission is

-rwxr-xr-x 1 messagebus users 71023 Feb  8  2012 /usr/local/softy/eclipse/eclipse

And I am able to open it directly from terminal like /usr/local/softy/eclipse/eclipse

How should I correct it?

share|improve this question
Could you add the output of ls -l /usr/local/softy/eclipse/eclipse? Also does it work running /usr/local/softy/eclipse/eclipse directly in terminal. –  Sneetsher Jan 18 '14 at 16:16
@Sneetsher I have edited the query. Have included what you asked. –  Prasanna Jan 19 '14 at 1:27

1 Answer 1

Remove 'bash' and make direct call:

alias eclipse='/usr/local/softy/eclipse/eclipse'

If there are other tools in that folder, You may want to add that folder directly to system PATH:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.