Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Has anyone managed to get the Citrix receiver client working in 64-bit Natty (11.04). It seems libmotif4 won't install multi-arch (32 bit and 64 bit libraries). I also see crazy dependency errors despite the libraries being present.

Here is what I received initially when trying to install icaclient.deb from Citrix;

sudo dpkg -i Downloads/icaclient_11.100_i386.patched.deb 
dpkg: error processing Downloads/icaclient_11.100_i386.patched.deb (--install):
 package architecture (i386) does not match system (amd64)
Errors were encountered while processing:

I then installed the 32 bit libraries.

sudo apt-get install ia32-libs ia32-libs-gtk

Then I noticed libmotif4 (a dependency of the citrix client) wasn't present so I installed the 64bit version.

sudo apt-get install libmotif4

I then tried to force the 32 bit version;

sudo dpkg --force-architecture -i Downloads/libmotif4_2.3.3-5_i386.deb    
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
Selecting previously deselected package libmotif4:i386.
dpkg: error processing Downloads/libmotif4_2.3.3-5_i386.deb (--install):
 libmotif4:i386 2.3.3-5 (Multi-Arch: no) is not co-installable with libmotif4:amd64 2.3.3-5ubuntu1 (Multi-Arch: no) which is currently installed

So I uninstalled the 64 bit version and tried to install the 32 bit version. This worked, but when I attempt to install Citrix I enter dependency hell.

sudo dpkg --force-architecture -i Downloads/icaclient_11.100_i386.patched.deb 
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
Selecting previously deselected package icaclient:i386.
(Reading database ... 183036 files and directories currently installed.)
Unpacking icaclient:i386 (from .../icaclient_11.100_i386.patched.deb) ...
dpkg: dependency problems prevent configuration of icaclient:i386:
 icaclient:i386 depends on libc6 (>= 2.3).
 icaclient:i386 depends on libice6 (>= 1:1.0.0).
 icaclient:i386 depends on libsm6.
 icaclient:i386 depends on libx11-6.
 icaclient:i386 depends on libxaw7.
 icaclient:i386 depends on libxext6.
 icaclient:i386 depends on libxmu6.
 icaclient:i386 depends on libxp6.
 icaclient:i386 depends on libxpm4.
 icaclient:i386 depends on libxt6.
dpkg: error processing icaclient:i386 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

So the state it's in, there's no icaclient binaries installed only the docs. It is complaining about libraries that are indeed present (libc6 64 bit and 32 bit). libmotif4 is only 32 bit installed and won't install alongside libmotif4 64 bit.

libmotif4 error when you try to install it alongside the 32bit instance;

 libmotif4:amd64 2.3.3-5 (Multi-Arch: no) is not co-installable with libmotif4:i386 2.3.3-5ubuntu1 (Multi-Arch: no) which is currently installed

Any tips?

share|improve this question
package architecture (i386) does not match system (amd64) Are you installing the i386 package on amd64 system? Sounds fishy but I might be wrong ;) – Rinzwind May 6 '11 at 19:16
There is only an i386 build of citrix receiver and it needs the 32 bit libmotif4 library. It fails the dependency when you only have the 64 bit present. Though, as you said maybe I'm doing something wrong. – krondor May 6 '11 at 20:05
up vote 2 down vote accepted

Already documented here, on the Ubuntu Community Documentation site.

The HOWTO explains how to install the 32-bit Citrix ICA client on either a 32-bit or 64-bit Ubuntu host. The process definitely looks compatible with other distros as well, since it:

  1. Avoids using the Apt packaging system, opting to install the ICA Client from a tarball.
  2. Describes how to identify the 32-bit libraries you may need using native tools like ldd.
  3. Explains how to resolve the 32-bit library issue by extracting only the required libraries from a .deb package and manually copying and linking them, which is easily translated to other distro package management schemes.
share|improve this answer
The official documentation works, though I'm disappointed I can't use the .deb Citrix provides. I do realize that's not an Ubuntu issue, however. I hope Citrix gets their 64 bit release out... – krondor Jun 9 '11 at 19:16
@krondor: they don't even release 32 bit software for windows (at least not on client side) – user694971 Feb 13 '12 at 13:17

They now provide a 64-bit version of the .deb package. Unfortunately, the 64-bit package checks if the system is a 32-bit system. Obviously, the check fails.

I've modified the package to properly check for 64-bit system (and 32-bit actually for no reason really).

You can find my modified package here.

It was literally a one character change to postinst. Hope this helps somebody.

Oh, please note that you will still need to copy or link to your certs directory.

share|improve this answer

I made sure that I uninstalled the 64 bit package, and dpkg --force-architecture -i libmotif4*i386.deb so that I installed the 32 bit package,, you can only have one or the other installed, not both at the same time as far as I know.

My Citrix receiver now functions. Regards,Tom.

share|improve this answer
Thanks, I'll try again with only 32 bit. I believe I had gone through this without a fix, are you on Natty? I'll mark answered after I test. – krondor May 12 '11 at 15:09
I've retested and this did not resolve the incident on my system. Thank you for the response though. – krondor Jun 9 '11 at 19:15
@krondor: I have a question to you: how is Citrix working on your Ubuntu system? I have here two 11.xx systems and it's no fun. Actually I even asked a question about the issue: Citrix Ubuntu 11.10, focus problems – user694971 Feb 13 '12 at 13:19
@user694971: I haven't noticed too many problems, but I expect it is your compositing that is the culprit. In 10.x I had problems with compositing and cube desktop. If I spun the desktop Citrix window fell below the desktop (still running, but no longer usable). Drove me crazy. I'll keep an eye out for focus issues on drop down per your question. – krondor Mar 1 '12 at 15:20
@krondor: Thanks, that matches very much with my experience... – user694971 Mar 12 '12 at 9:17

Use Getlibs

(You will find getlibs in ppa:jcollins/jaminppa)

getlibs -w  getlibs -w

sudo ln -s /usr/lib/ /usr/lib32/

The ICA client should now start normally:

# /usr/lib/ICAClient/wfcmgr -icaroot /usr/lib/ICAClient
share|improve this answer
Thank you for the info, I'm going to do some more digging but it doesn't look like this PPA has a natty version. – krondor Sep 21 '11 at 14:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.