Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded my Ubuntu from 13.04 to 13.10. And now after the system restart; there are only two options appears on screen as guest session and remote login.

How can I get back the manual login option in my login screen?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Open a terminal (press and hold Alt+Ctrl+T) at logon screen and enter below;

sudo /usr/lib/lightdm/lightdm-set-defaults --show-manual-login true

Reboot the system or simply type init 6 within the terminal itself to reboot.

Let us know here whether it works..

share|improve this answer
add comment

lightdm is the default display manager in Ubuntu. somehow your default value of lightdm has been modified. you need to set it back to get back the login option.

First you need to login to a virtual console, press Ctrl+Alt+F1 and enter your user-name and password.

Use the following command to set lightdm default values[source],

$ sudo /usr/lib/lightdm/lightdm-set-defaults --show-manual-login true
$ sudo reboot

It will bring back the manual login option in your login screen after reboot.

Alternate way

you can edit your /etc/lightdm/lightdm.conf by yourself and add the following line at the end,

greeter-show-manual-login=true

To edit either you can open the file with nano or vi as,

sudo nano /etc/lightdm/lightdm.conf

or, just use the following in the console,

sudo sh -c 'echo "greeter-show-manual-login=true" >> /etc/lightdm/lightdm.conf'

next reboot your system using, sudo reboot

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.