Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

EDIT: Using VGAswitcheroo is NOT possible because it's accessible only if the radeon module loads. But my whole problem is that the radeon card doesn't load, if Ubuntu tries to load it, it hangs.

[Ubuntu 13.04]

My HP DV6 6121tx's AMD card has developed some kind of strange hardware fault. So I'm running running Windows with only the Intel drivers, and the AMD card disabled. It runs well enough, I'm not having any issues (except of course I can't run high res games, but that's not a problem).

Now I really need a working Ubuntu installation on my computer, but I cannot figure out how to achieve the same with it.

Right after I install Ubuntu (no modifications), and I boot it, I get this screen.

enter image description here

If I use nomodeset in the boot options, Ubuntu boots up properly, but in 'Software Rendering Mode'. I've tried various other boot options including:


Can you guys guide me on how to disable/ignore/blacklist/uninstall the AMD Card from Ubuntu and use Intel Graphics ONLY in Ubuntu; like I'm using in Windows?

There's no option in my BIOS to disable the AMD card.

(I've marked it as urgent because being a Computer Science student, most of my coursework is Linux based)

Thanks a lot guys, I'll really appreciate if you guys can help me solve this huge headache.

share|improve this question

Check out this link to see if anything here works for you:

If that doesn't work try:

Add the following lines to /etc/rc.local above the 'exit 0' line

modprobe radeon
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

Then add this to /etc/modprobe.d/blacklist-local.conf

blacklist fglrx

Reboot and then check to see if it has worked by typing:

sudo cat /sys/kernel/debug/vgaswitcheroo/switch

You should see something like this:

1:DIS: :Off:0000:01:00.0

IGD is your Intel chip and the + means it is currently being used, and Pwr means it's on. DIS is the ATI card and if it says Off, then it as worked :)

share|improve this answer
vgaswitcheroo would work IF my radeon module loaded. But the whole issue is that the Radeon card is faulty and doesn't allow the radeon module to load! I hope you understand. I want to stop Ubuntu from trying to use the radeon card. Because as soon as it does that, it hangs. nomodeset bypasses that, but it also bypasses the Intel card! – user1265125 Jan 18 '14 at 15:41

You still not tried the radeon.blacklist=1 parameter to blacklist the radeon driver.

This might solve your problem, but it is possible that your AMD card will stayed powered on during sessions, generating more heat and causing less battery time.

share|improve this answer

If you're still having this issue, you can do what I did. I pressed the delete key at boot screen to access my bios screen. I then disabled switched graphics from bios. Then I installed ubuntu and Im not sure if it even looked for ati or not; however, it did see the intel graphics and works just fine.

Im sure you probably alreadyt tried this. I had to do it on my laptop because if I enable switchable graphics in bios, the ATI runs at full speed all the time and heats up my laptop and drains the battery.

I currently have an HP Probook 4540s. Im not good with the whole command prompt/terminal/konsole. So this is the route that I had to take. If all else fails, you can give it a try.

share|improve this answer

I know this is 2 years old, but I found a solution to this problem. You have to prevent your computer from even trying to load the radeon drivers.

cd /lib/modules/3.13.0-24-generic/kernel/drivers/gpu/drm/radeon
mv radeon.ko radeon.ko.bak

Note: this was on 14.04

Funny coincidence though, my laptop's also a DV6 6121tx. The 6770M served me well through 4 years of intense video-gaming (aka bachelors of engineering)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.