Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have searched for an answer but haven't found a simple solution or one that shares my setup. This problem should be pretty clear cut so maybe someone can help. Here's my set up.

  1. Have an HP dual-core machine, 2Gb ram. Using Ubuntu 12.04, with lubuntu-desktop installed. Works great. My original install was version 11 of Ubuntu about 2 years ago, and I replaced the USB network adapter about 18 months ago with more up-to-date model capable of "N" speeds.

  2. I ditched network-manager in favor of WICD which is more user friendly, but the problem I am having existed before WICD was installed and before lubuntu/openbox desktop was added. It also existed with my previous wireless adapter.

  3. The encryption on my router is WPA2 with PSK. This is the only secure encryption that works with wireless-N.

  4. Using a USB wireless N adapter. Lsusb and iwconfig output here:

    Bus 001 Device 003: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
    
    wlan1     IEEE 802.11bgn  ESSID:"K********"  Nickname:"rtl_wifi"
              Mode:Managed  Frequency:2.437 GHz  Access Point: 58:6D:8F:A4:DE:92   
              Bit Rate:72 Mb/s   Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=91/100  Signal level=82/100  Noise level=0/100
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
  5. So my workaround is to remove the USB adapter and reinsert it after the computer wakes up. But I don't want to have to do that all the time. It appears to be a problem related to wpa_supplicant... my guess is that Ubuntu does not configure it properly and manual tweaking is needed to make the power management work. I did install wicd and wicd-gtk last week and removed the network-manager packages. I did a purge on network manager and it still seems to work fine. I don't want to play with it on my own as it works, but it would be nice if someone found a fix. I don't even know what the proper location of wpa_supplicant.conf should be or whether it matters.

  6. I tried using iwconfig to turn on power management in the device and it did not do anything. Though I don't think this is the real issue.

  7. logs indicate there may be a problem with wpa_supplicant...

    $ tail -50 /var/log/pm-suspend.log
    
    Running hook /usr/lib/pm-utils/sleep.d/60_wpa_supplicant resume suspend:
    Failed to connect to wpa_supplicant - wpa_ctrl_open: No such file or directory
    
    /usr/lib/pm-utils/sleep.d/60_wpa_supplicant resume suspend: success.
    Running hook /usr/lib/pm-utils/sleep.d/55wicd resume suspend:
    
    /usr/lib/pm-utils/sleep.d/55wicd resume suspend: success.
    Running hook /usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend:
    Having NetworkManager wake interfaces back up...Failed.
    
    /usr/lib/pm-utils/sleep.d/55NetworkManager resume suspend: success.
    

As you can see, 55NetworkManager is still a process in my system (which suggests that WICD still depends on it?). BTW, pm-utils is installed and depends on a large number of packages:

acpi-support gnome-power-manager gnome-session gnome-session-bin indicator-power indicator-session lubuntu-desktop nautilus-share pm-utils ubuntu-desktop upower xfce4-power-manager

What should I try next?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.