Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Vanilla install of Ubuntu 13.10 on my MSI Wind U100. Intel graphics card I think.

Auto brightness flickers up and down, brightness hud display top-right also flickers. Interrupts input so need to restart to fix. Issue is triggered by attempting to adjust screen brightness by Fn+F4/Fn+F5, looking at the Brightness & Lock control panel in System Settings, or when laptop goes into battery saving mode (or whatever happens when the battery gets really low).

Very similar to this issue.

Issue is temporarily fixed with this code:

sudo chmod u-w /sys/class/backlight/acpi_video0/brightness

but issue returns after a restart. Prior to running this code the brightness settings do not appear in Brightness & Lock, after running this code the brightness settings appear but the brightness slider doesn't work.

Thank you!

share|improve this question

1 Answer 1

I cannot help you to resolve the issue itself, but you can workaround by executing the mentioned command when booting. To do that simply put

chmod u-w /sys/class/backlight/acpi_video0/brightness

in /etc/rc.local. (Open with text editor of your choice and add the line before exit 0.) Remember, you need to have root rights to do that.
For adjusting the brightness have a look here: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/415023/comments/347

This is a known bug: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/415023 so I am afraid you will have to wait for the bug being solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.