Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have inherited a 32 bit PC which has two SATA drives and a hardware RAID card setup for Raid 1 mirroring. The PC is empty and as I need a local server for some web development work I decided to install 12.04 Server on it. CD installing ok until I got to the drives part.

One or more drives containing Serial ATA RAID cofig found ... Activate Y/N?

Whether I select "Y" or "N" I end up in the Partition Disks menu.

 - Configure LVM
 - Config Encrypted Vol
 - Config iSCSI vol
 - RAID 1 device #126 - 78.2 Gb Software RAID device
 -   #1 78.2 GB
 -   512.0 B unusable
 - RAID 1 device #127 - 4.1 Gb Software RAID device
 -   #1 4.1 GB
 -   512.0 B unusable

Which I presume is telling me I have SoftwareRaid from a previous incarnation - and I don't want it. But I don't seem to be able to get rid of it. All I can do in the "#1" options is erase all data - which I have done.

I read somewhere that I can only remove the software RAID by booting with Live CD and doing it from there .. I tried (32 bit 12.04.3 CD) but as soon as I go into the "Try Ubuntu" I get a million error messages flying past .. unable to find directory/file combinations till it hangs.

So where from here?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Choose configure raid arrays ( should be the next item up from configure lvm, so you seem to have cut it off in your post ), and delete the software raid arrays if you don't want them. Since you also got the message about serial ata raid, it seems that you have also used these drives in a fake raid setup. Most likely your "hardware raid card" is a fake raid. If it is, and you don't need to dual boot with windows, then it is best to avoid that and just go with regular software raid, which is better supported.

If you go into the bios and delete the raid array there ( don't just disable the raid functions, actually delete the array ), and that gets rid of the serial ata raid message, then you have a fake raid card and should proceed with setting up a plain software raid array.

share|improve this answer
    
Hi. Thanks for the reply. The top menu option is Configure LVM. There is nothing above it - nothing cut off. So this is why I don't know how to delete the software RAID. Yes, as I said, it seems that software RAID has been setup in the past but I don't want that now as the PC has hardware RAID. Not sure what you mean by "your hardware RAID card is a fakeraid" as it's a real RAID card from Promise and it is shown when the PC is booting up. I have set this up to be RAID1 Mirroring and I want to continue using this rather than software RAID as it will take some of the load off the CPU. –  Upland Jan 17 at 20:30
    
@Upland, nope, promise is fake raid. The card is a regular old AHCI SATA controller, with special Windows drivers and a bios extension that performs the raid in software. It takes no load off the cpu, so you are better off sticking with software raid in Linux. Fakeraid's only purpose is to trick windows into doing raid since it has poor software raid support. –  psusi Jan 17 at 21:08
    
ok thank you for the tip. I will give it a try over the weekend and see if I can get to the bottom of it. But I still don't get why the Desktop CD gives me a gazillion errors on startup but Server goes through everything perfectly - at least till I get to the disks. I will see if it still persists after I get the Raid off. –  Upland Jan 17 at 21:19
    
@Upland, the problem is that you are trying to use the disks in two different software raid setups at the same time, so things get confused. You need to get rid of one of them. Also thought I'd throw out one more tip: you can use raid10 instead of raid1 to get better read performance ( near raid0 ) while keeping the redundancy. To do this, you will want to manually run mdadm to create the array and use the -C argument to set the chunk size to something like 4M instead of the default 512k, and the -p switch to set the layout to offset instead of the default near. –  psusi Jan 17 at 21:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.