Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on Xubuntu 13.10 64 bit. I want to change the default terminal emulator to Terminator. Currently the default terminal emulator is Xfce-Terminal. I do

sudo update-alternatives --config x-terminal-emulator

I get

 Selection    Path                             Priority   Status
------------------------------------------------------------
  0            /usr/bin/terminator               50        auto mode
  1            /usr/bin/koi8rxterm               20        manual mode
  2            /usr/bin/lxterm                   30        manual mode
* 3            /usr/bin/terminator               50        manual mode
  4            /usr/bin/uxterm                   20        manual mode
  5            /usr/bin/xfce4-terminal.wrapper   40        manual mode
  6            /usr/bin/xterm                    20        manual mode

Press enter to keep the current choice[*], or type selection number: 

It does not matter if I choose 0 or 3 The default terminal is Xfce-Terminal. I mean:

  • Super key + T will open Xfce-Terminal
  • Right click -> Open Terminal here will open Xfce-Terminal

I'm used to configure Crunchbang, Openbox is easy to configure, but on Ubuntu + Xfce I don't know what to do: Should I configure some files? Should I run a terminal command? Should I use Nautilus actions?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I think there's an option to do so using the GUI, though I've never needed to change my terminal, I did go through a period of using PCManFM before Thunar had tabs.

I think it's under Settings Manager >> Preferred Applications >> Utilities (or something like that).

Maybe also purging the others would provide a solution - but I've tried to remove default packages in the past and found they're dependancies of xubuntu-desktop (which, obviously, you don't want to remove).

share|improve this answer
1  
You might also have to change the key bindings to specify your key combo to open your terminal of choice...I think this is under the 'keyboard' option, though there might be an option under something like 'keyboard shortcuts'. I can't remember and can't check atm since I'm working from Windows - will check back in a few hours and post from my Xubuntu installation if you're still having trouble. –  ArminasAnarchy Jan 17 at 17:37
    
it worked, thank you! do you know why the terminal command didn't work? –  Fischer Jan 17 at 17:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.