Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have tried to install Ubuntu alongside Windows 8.1 on my portable DELL Inspiron.

I have been through problems, which, everytime I tried to solve, brought other bigger problems...

  1. First, I installed Ubuntu 12.04 (from official website) with a burnt DVD. (Legacy mode) I partitionned my hard disk :

    • 5Gb, type : ext4, mount point : /
    • 6Gb, type : ext4, mount point : /home
    • 1Gb, type : swap
    • 2Mb, I don't remember the type, but the installation device adviced me to do that

    The installation worked, but when I restarted, I had a black screen

  2. So I decided to install Ubuntu 13.10 (official website) with a burnt DVD too. (Legacy mode) I formatted the ext4 partitions and installed ubuntu 13.10

    The installation worked, but when I restarted, I had an error : "variable root isn't set" and the loading screen of ubuntu couldn't finish.

  3. So I decided to use the boot-repair disk. I burnt it on a CD and ran it. (Legacy mode) I followed the instructions, but when I restarted, I had this error : "invalid arch independent ELF magic" "grub rescue> "

    So I ran the boot-repair disk again, still the same error.

    However, when booting in UEFI mode (to access Windows), I didn't have this error. (remark : when executing the boot-repair disk instructions, I had this error : "Fatal : could not open either sysfs or procfs directories for accessing EFI variables. Try 'modprobe efivars' as root")

  4. At last, booting in UEFI, boot secure option disabled, I have now this GRUB screen :

    • Ubuntu with Linux 3.8.0-35-generic
    • Ubuntu with Linux 3.8.0-35-generic (recovery mode)
    • Previous Linux versions
    • Windows UEFI recovery bkpbootmgfw.efi
    • Windows boot UEFI recovery
    • Windows recovery environment (loader) (on /dev/sda1)
    • Windows (on /dev/sda5)
    • System set up

When I choose Windows recovery environment (loader) (on /dev/sda1) or Windows (on /dev/sda5), I have this error : unknown command 'drivemap' invalid EFI file path. When I choose Windows UEFI recovery bkpbootmgfw.efi or Windows boot UEFI recovery, it's OK, I can reach and use Windows.

When I choose Ubuntu with Linux 3.8.0-35-generic, I can see some bluetooth error, and then I have the unavoidable black screen.

When I choose Ubuntu with Linux 3.8.0-35-generic (recovery mode), it's OK, I have a menu where I can choose several options. So then, I chose graphic safe mode -> reconfigure graphics (default), and then, low graphics boot for one session, and then update grub bootloader. At last, I clicked on standard boot, and I reached for the first time the ubuntu desktop. I restarted, but the Ubuntu with Linux 3.8.0-35-generic choice still gives me a black screen.

Besides, booting UEFI with boot secure option enable, gives me for the first time : "secure boot violation, invalid signature detected. Check secure boot policy on setup", and then "internal hard disk drive not found blablabla, no bootable devices blablabla". From this message, I have several options, I chose "check PSA" or something like that. I am waiting now for the checking.

What afraid me is that now, to access Windows, I must go through one of the two boot recovery GRUB options, AND also must have the boot secure option disabled.

What annoy me is that I still can't use Linux on my computer (which is new, I bought it 2 weeks ago...), and I need it to work.

Any help ??? please.....

share|improve this question
for the part where Ubuntu boots into a black screen you can have a look at this question – Wouter Jan 17 '14 at 13:34

Actually, now, I don't have black screen anymore.. it's worse :p

I sum up the current state of my boot :

  • Legacy mode -> error : invalid arch independent ELF magic grub rescue>

  • UEFI mode, secure boot disabled -> GRUB options :

ubuntu Linux 3.8.0-35 generic -> bluetooth error -> loading ubuntu screen -> message : "the system is running in low-graphics mode" -> if click on "run in low-graphics mode for just one session" -> some code lines (starting blabla, stopping blabla, ...) (first line : could not write bytes : Broken pipe), and then if I enter some arrow keys I have : Ubuntu 12.04.3 LTS olivier-Inspiron-5437 tty6 olivier-Inspiron-5437 login: then password and I am in linux console

ubuntu Linux 3.8.0-35 generic (recovery mode) -> recovery menu -> if click on "resume normal boot" -> I can use ubuntu :) !

Windows UEFI recovery bkpbootmgfw.efi OR Windows boot UEFI recovery -> can use Windows :)

Windows recovery Environment (loader) (on /dev/sda1) OR Windows (on /dev/sda5) -> error : unknown command 'drivemap' invalid EFI file path

  • UEFI mode, secure boot enable -> error : Secure boot violation. Invalid signature detected. Check secure boot policy on Setup, and then internal hard disk drive not found. To resolve this issue, try to reseat the drive, No bootable devices-- F1 to retry boot, F2 enter Setup Menu, F5 enter PSA

So I have two problems : the biggest is that my boot has some problems, and I can't boot windows normally (I have to use a boot UEFI recovery with secure boot disabled) ; the second is that I can't boot Linux normally neither (I have to use the recovery mode)

Now, i am afraid of doing anything to repair these issues, afraid that it will get worse again..

share|improve this answer
what is strange too is that I installed ubuntu 13.10 over 12.04, but the ubuntu I can use (in both recovery and normal modes) is 12.04 LTS, and in the GRUB version it's written ubuntu13.14 – pikron Jan 18 '14 at 9:50
up vote 0 down vote accepted

I eventually succeeded in restore my computer. I give my way to other people who could have the same problem. Actually, I removed Linux and then restored the windows boot (which both didn't boot normally).

I first deleted the Linux partitions as follows (so save files before if needed) (do it if linux was installed on its own partition -> if installed with Wubi, go to control panel-> programs-> uninstall program-> select Ubuntu-> uninstall) :

  1. go to disk management by pressing WinKey + X or write diskmgmt.msc, in the search menu then choose diskmgmt

  2. right click on the linux partitions, and delete them (the linux partitions can be recognized by right cliking on them, select property, and seeing that they have no label for file system, as they are detected as unknown partitions). Be careful to not delete other partitions.

  3. Extend the C: partition with the obtained free space (right click-> extend volume) or format the free space if you want to reuse it later.

Here, Linux was deleted from my computer,but not its bootloader. Thus, if I restarted at this point, I would have the following error : no such device: *a number* grub rescue>

So I repaired the windows boot, by rebooting my computer using a bootable USB windows recovery drive. Create a USB recovery drive.

Here, check the partition table type : MBR or GPT as follows : in disk management (see before), right click on the left "box" on the left of your partitions (Disk 0), select properties, go to Volumes, and see Partition style

Boot on the USB drive, choose a keyboard, choose advanced options, and then the command line.

When in the command line,

For me (GPT solution), it worked perfectly (the windows recovery options changed a little, that's all)

Good luck !

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.