Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My machine froze on my screensaver yesterday so i forced a shutdown. Now i can't reboot into my GUI - TTY works.

The fail message i receive on startup is "No suitable module for running kernel found".

I'm running kernel 3.12.2, i have an optical drive, so can repair from a live CD if necessary.

I can also boot into recovery mode where i've run fsck, clean (admittedly /boot has only 10mb free - been trying to fix that) and dpkg.

On a start from recover mode my fail message says "starting virtualbox kernel modules".

Any help would be wonderful, and i'll be sure to send plenty of love your way!

Update: I have purged VirtualBox from root in recovery mode and have tried rebooting using kernel 3.12.2 - crashes at "starting ACPI daemon," and 3.8.0.34 and 35 where it crashes at "Stopping save kernel messages."

Other kernels installed are: 3.8.0-26 and 3.8.0-25

share|improve this question
    
How did you force shutdown? –  Takkat Jan 17 at 11:57
    
power button for 8 seconds. –  Coufeyrac Jan 17 at 12:01
    
You may have issues with your filesystem then. A forced shutdown should never be made with the power button (use "magic SysReq" keys instead). See askubuntu.com/questions/40433/… if you can repair it and backup your data when they are still accessible from CLI. –  Takkat Jan 17 at 12:11
    
i tried the sysreq to thaw and shutdown, but the system remained unresponsive. –  Coufeyrac Jan 17 at 12:16
    
Unfortunately your suggestion didn't work. It comes back saying the superblock cannot be read and may be corrupted. I've tried leading a saved superblock (several in fact), but all give the same answer. Any other ideas? –  Coufeyrac Jan 17 at 13:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.