Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to setup bumblebee, but until now I get this message:

me@105999hmolt:/usr/lib/nvidia-current-updates/xorg$ optirun glxspheres 
primus: fatal: broken GLX on main X display

I've noticed that some libraries couldn't be found:

me@105999hmolt:/usr/lib/nvidia-current-updates/xorg$ ldd *
 libglx.so:  
 linux-vdso.so.1 =>  (0x00007fff059f2000)  
 libnvidia-tls.so.304.88 => not found  
 libnvidia-glcore.so.304.88 => not found  
 libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f3a346c0000)  
 libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f3a344bc000)  
 /lib64/ld-linux-x86-64.so.2 (0x00007f3a355c0000)

 libglx.so.304.88:
 linux-vdso.so.1 =>  (0x00007fff04bff000)
 libnvidia-tls.so.304.88 => not found
 libnvidia-glcore.so.304.88 => not found
 libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f93a2d4d000)
 libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f93a2b49000)
 /lib64/ld-linux-x86-64.so.2 (0x00007f93a3c4d000)
 nvidia_drv.so:
 linux-vdso.so.1 =>  (0x00007fff14bff000)
 libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f16d50a3000)
 libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f16d4ce4000)
 libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f16d4adf000)
 /lib64/ld-linux-x86-64.so.2 (0x00007f16d5db9000)

The corresponding Xorg.0.log can be found here http://pastebin.com/rbRR6e74

The missing libraries are installed on my system, but could they be from the wrong package? Does anybody know where I can get the md5 sums?

9b6da122a85bfe2f4db8897c0f5ea7b3  /usr/lib/nvidia-current-updates/libnvidia-tlibnvidia-tls.so.304.88
9b6da122a85bfe2f4db8897c0f5ea7b3  /usr/lib/nvidia-current-updates/libnvidia-tls.so.304.88
82c630b36b20ff68f1017a7bd0a75599  /usr/lib/nvidia-current-updates/tls/libnvidia-tls.so.304.88
9b6da122a85bfe2f4db8897c0f5ea7b3  /usr/lib/x86_64-linux-gnu/xorg/x11-extra-modules/libnvidia-tls.so.304.88
9b6da122a85bfe2f4db8897c0f5ea7b3  /usr/lib/x86_64-linux-gnu/xorg/x11-extra-modules/libnvidia-tls.so.304.88.old
9b6da122a85bfe2f4db8897c0f5ea7b3  /usr/lib/xorg/modules/libnvidia-tls.so.304.88
9b6da122a85bfe2f4db8897c0f5ea7b3  /usr/lib/xorg/modules/extensions/libnvidia-tls.so.304.88  
af8b194067c6120f389b1061b5dd45b1  /usr/lib32/nvidia-current-updates/libnvidia-tls.so.304.88  
f2ab26d6c0e49b512bdf102e2d1a4065  /usr/lib32/nvidia-current-updates/tls/libnvidia-tls.so.304.88  
a589f3081fbd537bc1305644115eb4cc  /usr/lib/nvidia-current-updates/libnvidia-glcore.so.304.88
9b4371241ccc86a046d6e2ad65210ec1  /usr/lib32/nvidia-current-updates/libnvidia-glcore.so.304.88
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.