Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install ubuntu Server to a RAID5 array. I have three, 3Tb disks, each with a GPT partition table. I have set up my partitions as follows:

/dev/sda
1. 512 Mb physical RAID volume
2. 3 Tb pysical RAID volume

/dev/sdb
1. 512 Mb physical RAID volume
2. 3 Tb physical RAID volume

/dev/sdc
1. 512 Mb physical RAID volume
2. 3 Tb physical RAID volume

The raid volumes are grouped into two md devices:

1. 1.5 Gb RAID5 (mount point:  swap)
2. 6.0 Tb RAID5 (mount point:  /)

Installation proceeds normally until it is time to install GRUB2. I get an error that reads:

Unable to install GRUB in /dev/sda
Executing `grub-install /dev/sda` failed.
This is a fatal error.

Why is this happening and what can I do to fix it?

share|improve this question
    
I would suggest try with another bootloader but i don't know if Ubuntu will let you choice –  user091230912 Jan 16 at 21:18
    
@Felipe.M - and what bootloaders would that be? It is more whether the bootloader will run Ubuntu, not whether Ubuntu will let it... You could use EasyBCD to modify a Dual-Booted Windows bootloader. blz - how are you implemeting this? Is this from a working system, or a Live Disk? And shouldn't the installer do this for you? If it boots, it works :-s –  Wilf Jan 16 at 22:20
    
@wilf, this is precisely my problem -- the installer should do this, but it fails with the error message I reported above. Again, for clarity, this is all taking place in the ubuntu-server text isntaller. –  blz Jan 16 at 22:47

1 Answer 1

up vote 1 down vote accepted

It seems that GPT-partitioned drives require a bios_boot partition when used in conjunction with BIOS. Here is a tutorial that worked for me.

Also note that one of the drives subtending the RAID array must have a /boot partition configured. Again, for clarity, you will need:

  1. A small (~1 MB) bios_boot partition
  2. A /boot partition

begin rant

Holy uninformative error message, GRUB! Good lord!

end rant

share|improve this answer
1  
I don't know what this 'BRUB' is that you tried to install, but grub does give a bit more informative error message. –  psusi Jan 17 at 2:31
    
@psusi, I beg to differ. The grub error above is what I was presented with, verbatim (minus the typo). –  blz Jan 17 at 3:36
    
Yeah, really need <rant> tags... –  Wilf Jan 17 at 10:43
    
Did you not read the first part of my comment? You weren't installing grub.. or was that just a typo? There are a few goofy forks of grub out there that people use, I think another one was called BURG... at any rate, there should have been another line you cut off above that one saying something about gpt, and no bios_grub found... –  psusi Jan 17 at 14:43
    
@psusi, I did, hence the bit about the typo =) I was installing GRUB, but my stupid brain decided to type BRUB. –  blz Jan 17 at 21:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.