Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to create a live linux USB and have encountered a variety of the most vexing problems. Short story: I can't get the USB to boot, but the symptoms are different with every attempt. The only thing in common is that I haven't succeeded yet.

Background:
I have 2 USB sticks, each of which has previously successfully been used to create a live linux USB. I was playing around with distros, and created them using a variety of tools, including LiLi, YUMI, LiveUSB Creator, Universal-USB-Installer and the ubcd instructions on command line. I may have also once succeeded creating one completely from command line instructions. BOTH of these USB sticks never had any problems, neither did my BIOS, up until...

Background II:
I decided to try making a hackintosh on my 5yr old computer. The specs were just a little out of date, but I found people who had similar builds, so I thought I would give it a go. It was a complete failure, with all sorts of problems, and I'm resigned to failure there. The crux of this point is that I used both of these USB sticks in the attempt, which meant putting them in my macbook to make them bootable on my PC.

Current:
After I gave up the hackintosh project, I decided to go ahead with my linux installation, but now I can't get my USB sticks to boot. I have tried creating install USBs using Windows, Mac OSX and Linux (on an old partition). My typical results are:

USB made from Windows - BIOS doesn't recognize the USB HDD and therefore I can't boot from it. USB made from Mac/Linux - BIOS recognizes the USB HDD and boots, but then says "missing operating system".

I think I have gotten several other results, too, like a boot: prompt with no grub UI (I think the USB boot failed and it tried to move on to another disk at that point), but frankly I've done this so many times with so many different tools, command line instructions, etc., that it's all blurring together.

Other that a solicitation for general advice, one question I have is whether it is possible to "ruin" a USB stick by making it bootable using a Mac, and then trying to do so from Windows. I have done slow formats, quick formats, installed the boot files by hand, used the tools, etc. and this whole thing is becoming very discouraging.

Thanks for your help, if you can provide any.

p.s. I can provide specs for my computer if they're relevant.
p.p.s. I have a 3rd USB stick with my Windows 7 installer on it that still works just fine. It was never included in the Hackintosh project, so it was never made bootable on a Mac.
p.p.p.s. All of these are "made on" not "made for" - meaning they were all for booting a PC, whether I used a Mac, Windows or Linux to create the install USB.
p.p.p.p.s. The USB sticks are all always FAT32 formatted.

UPDATE I have more information, but it's still bleak: 1) I tested my USB sticks on a different computer and they work fine. 2) I fixed all my mbr issues on my computer and confirmed that I can boot into the installed OSes without problems, but the USB sticks now all give me, without variation, the error: "No DEFAULT or UI configuration directive found" and they are not detected by my bios. These very same sticks work in my laptop, but not my computer. And I can still create Windows 7 installer USB sticks which do work in my computer - only the linux USB sticks are not working, and only in this computer. This defiance of reason is really driving me nuts.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.