Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Wacom Bamboo P&T CTH-661 and it works out of the box in Ubuntu 11.04. The problem is when I move the cursor over the edges of the screen, it 'jumps' a lot (it's very annoying and it gets very difficult to use the unity bar or the scrollbar)! Is there any way to define the correct area/boundaries?

I've tried setting the area in xsetwacom (bottom x, bottom y, top x, top y), but all it does is reduce the defined area (the problem does not go away...). I've also tried MapToOutput, but without success.

Any thoughts?

share|improve this question
add comment

2 Answers 2

Not sure if any of this will help, anyway here it goes. On my Wacom Intuos 2 I can change some properties such as the usable area via xinput, some examples commands would be (in this case from changing to a 16:10 aspect ratio):

xinput list xinput list-props "Wacom Intuos2 6x8" xinput set-int-prop "Wacom Intuos2 6x8" "Wacom Tablet Area" 32 0 1770 20320 14470

Maybe some of those props will help you with your problem.

share|improve this answer
    
I've set those parameters in xsetwacom and, although it solves the top and left boundaries, it does not work with bottom and left. Is it different to change parameters in xinput rather than in xsetwacom? What is the first value (32)? Thanks a lot –  pedroo May 7 '11 at 7:56
add comment

My only suggestion would be to firstly report a bug to the Wacom Linux project: http://linuxwacom.sourceforge.net/ Make sure you include easy to follow step by step instructions on how to replicate the bug and what you've tried to remedy it.

Only once you've set down everything in the problem should you then suggest what you think might solve the problem. At this point given your description it doesn't sound like redefinition of bounding would help.

Secondly, you might like to try either non-absolute position via xsetwacom or using the keyboard in order to load unity icons. Super+Number will load that item from the list. I know this doesn't fix your bug, but it might help you while it's being investigated.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.