Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 2 year old laptop (an ASUS K73SV, 8Gb RAM, intel i7-2630QM, nVIDIA GeForce GT540M 1Gb) and the GPU setup is a hybrid system (which means it switches between the intel HD integrated in the CPU).

I'm running only Ubuntu 13.10 atm and any proprietary driver installation of Nvidia has failed. Bumblebee, optimus, etc..

Is there anybody out there who can tell me if it's even possible to install proprietary drivers on my laptop? (or somebody with a similar setup who found a miraculous way to install and use them?).

I have been trying over a year to find something and this is my last resort ;).

Thank you for trying to help me!

EDIT: To clarify, before I installed the nvidia drivers without bumblebee, I just got stuck with a black screen at boot. I'd had to mess around with the command line to get everything working again but it did work again. Then I tried bumblebee, I thought it didn't work because nothing really changed (optirun). Now I have bumblebee installed but no idea how I should check if it works...

share|improve this question
    
You should probably edit your question adding more details like what went wrong when you tried to install nvidia drivers and bumblebee. Have you followed the instructions here: wiki.ubuntu.com/Bumblebee#Installation –  GabrielF Jan 16 at 12:26
    
@GabrielF, I installed it yet again with this link you gave me (I did install this many times before), but I don't see anything that is changing. The optirun cmd seems like it does nothing, because my fps are completely the same with glxgears. Or is this a bad way of testing if bumblebee works? –  MichelMichels Jan 16 at 13:17
    
Another interesting post: askubuntu.com/questions/366580/… –  GabrielF Jan 16 at 17:35

1 Answer 1

If you've followed the instructions here, you should probably have installed bumblebee-nvidia and primus, right? I believe primus gives a better performance over virtualgl. The latter is still the default, though, so you should run optirun with the -b primus option: optirun -b primus glxgears. See if you get a better performance.

Also, have a look on this post, which is very enlightening: http://askubuntu.com/a/36936/169250

EDIT: Try to update your nvidia drivers:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get install nvidia-331
sudo apt-get --purge autoremove #this should remove old drivers
sudo apt-get reinstall bumblebee bumblebee-nvidia

EDIT2: Apparently, you'll need to change a configuration file. See here (under Updating Drivers): https://wiki.ubuntu.com/Bumblebee#Installation

And it seems that running optirun nvidia-settings you can probably see if the nvidia GPU is working.

share|improve this answer
    
My performance is the same... This is really weird because I played TF2 on windows with max settings and now I have to set them to low just to get some decent gameplay. I guess it's just helpless.. This is never going to work –  MichelMichels Jan 16 at 16:27
    
I believe nVidia GPU is not running... try updating the nvidia drivers. I've edited the answer. –  GabrielF Jan 16 at 17:30
    
I can't install the nvidia-331 driver, it says it conflicts with something else (and yes I did sudo apt-get update after adding the ppa ;) ). This is what I got from the terminal (sorry it's in dutch but you could recognize the packages I guess): –  MichelMichels Jan 18 at 9:33
    
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'. De volgende informatie helpt u mogelijk verder: De volgende pakketten hebben niet-voldane vereisten: nvidia-304-updates : Conflicteert met: libopencl1 Conflicteert met: xorg-driver-binary nvidia-331 : Aanbevelingen: nvidia-settings-331 maar het zal niet geïnstalleerd worden Conflicteert met: libopencl1 Conflicteert met: xorg-driver-binary E: Fout, pkgProblemResolver::Resolve maakte scheidingen aan, dit kan veroorzaakt worden door vastgehouden pakketten. –  MichelMichels Jan 18 at 9:34
    
Try removing older nvidia drivers (it seems nvidia-304-updates is installed): sudo apt-get purge nvidia-*. I believe this will remove bumblebee-nvidia, so don't forget to install it along with nvidia-331 after that. –  GabrielF Jan 20 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.