Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had Problems with Skype for a bit, but managed to fix some of them (using Skype from the repos to make it work with Pulseaudio, fixing cracking sounds as described in http://itbubbles.wordpress.com/2013/10/21/xubuntu-13-10-sound-issues-skype-distorted-microphone-crackling-sound-indicator-disabled/).

Now I have a rather odd Problem: I have different Ubuntu accounts for work and private, and Skype works fine in my work account, but in my private user account, the microphone doesn't work. (I think I did the last Skype reinstall on the work account).

The microphone works well in other apps, but only silence in Skype (though I can hear the other side just fine). But the Skype recording does seem to transmit system sounds (Skype notification sounds are recorded/transmitted).

I tried with a clean Skype profile (dumping the ~/.Skype dir), but no effect. I'm on XUbuntu 13.10, Skype 4.2.0.11.

Any ideas?

What settings could be saved user-specifically? Access right issues? User-specific audio settings?

Thanks in advance, Manuela

share|improve this question

2 Answers 2

up vote 1 down vote accepted

"The microphone works well in other apps, but only silence in Skype (though I can hear the other side just fine). But the Skype recording does seem to transmit system sounds (Skype notification sounds are recorded/transmitted)."

So your problem is that skype is recording from the monitor source of your sound card and not from the microphone. To solve this install pavucontrol:

sudo apt-get install pavucontrol

then launch it and go to the Recording tab. Now initiate a test call in Skype. Skype will show up in the recording tab and it is likely recording from a monitor, like in this screenshot:

Skype recording from monitor source

Change it to record from your proper input source, e.g. see this screenshot:

Skype recording from a correct source

Pulseaudio should remember your choice, so next time you won't have to go into pavucontrol.

share|improve this answer
    
Yay, that was it! I did have pavucontrol, but didn't check settings while recording (which is when that setting is visible) ... Thanks! –  Manuela Hutter Jan 17 at 15:49

try re-intsalling your microphone driver. I had the similar problem. When I installed new microphone driver my problem was gone...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.