Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After an update with these packages:

x11proto-render-dev 0.11.1-2
x11proto-xinerama-dev (1.2.1-2)
x11proto-damage-dev (1.2.1-2
x11proto-core-dev (7.0.24-1)
nvidia-setting x11-dev  64 (1.6.1-1ubuntu1)
x11proto-kb-dev (1.0.6-2)
xtrans-dev (1.2.7-1) 
x11proto-fixes-dev (5.0-2ubuntu2)
nvidia-319-updates (319.60-0ubuntu1)
libxfixes-dev (5.0.1-1ubuntu1)
libxrandr-dev (1.4.0-1ubuntu2)
x11proto-xext-dev (7.2.1-1)
libxrender-dev (0.9.8-1)
x11proto-composite-dev (0.4.2-2)
libxinerama-dev (1.1.3-1)
libgtk2.0-dev (2.24.20-1ubuntu1)
libxcursor-dev (1.1.14-1)

My Gnome3 cannot work properly anymore. I can login successfully, but I just get a blank screen, and the cursor. I have installed Unity and KDE on the same machine. Unity has the same problem, KDE works.

Hardware

My video card is an Intel i915:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor
Family Integrated Graphics Controller (rev 09)

I have two monitors, one connected with VGA, the other one with DVI.

Logs

Grepping the Xorg.log for errors, I found this:

[1817.840] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

But I don't know if it could be related...

Note

Yesterday I shutdown the system when it was in standby (I know standby is not working, so I had to do that).

What can I do to have my loved Gnome3 back and running? :)

share|improve this question

1 Answer 1

It was the nvidia driver. Installed to provide opencv...

sudo apt-get remove nvidia-319-updates

Fixed it. I can't understand why it installed that package in the first place. Anyway, now it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.