Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a running redmine version 1.3.2 on my ubuntu 12.04 already, and now i am trying to install a new 2.4.2 version at a different location.

I used RVM to install ruby 1.9.2 and I need the passenger mod to run the application.

I guess the to problem is in my passenger.conf location settings that's what I found out.

PassengerRoot /usr PassengerRuby /usr/share/ruby-rvm/rubies/ruby-1.9.2-p180/bin/ruby PassengerDefaultUser www-data

With that configuration I receive an internal 500 error already from redmine...

apache2 error.log shows this :

from    <internal:lib/rubygems/custom_require>:29:in `require'
from    /usr/lib/phusion_passenger/passenger-spawn-server:53:in `<main>
Unexpected error in mod_passenger: Cannot spawn application '/var/www/redmine2'

I also think that I might not have the passenger gem correctly installed. How to install the gem to the current select rvm ruby version ? Since I can't find it in my gemlist in this directory. That would be very helpful to understand how to install gems correctly using RVM.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.