Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently got the final version of Ubuntu Natty Narwhal x64 and everything is working just fine. The only thing I am having trouble with is the boot screen. After I installed the proprietary nVidia drivers, the boot screen becomes corrupt and only shows text (as it has been doing since Ubuntu 10.04). When I followed the instructions to fix the boot screen in 10.04 and 10.10, the boot screen still remains the same and the problem isn't resolved. Please give a full guide on how to fix this problem.


Machine Details

Computer : HP Pavilion p6240in

  1. Processor : Core 2 duo

    Memory : 4096 megabytes

    Graphics : nVidia G210 3d graphics

Monitor : Dell 17 inch lcd


Another question I would like to ask is whether it is possible to use this script (http://www.webupd8.org/2010/10/script-to-fix-ubuntu-plymouth-for.html) with 11.04. I am asking this question because it says that the script works only with 10.04 and 10.10.

share|improve this question
    
post here output of command grep CMDLINE /etc/default/grub –  Denwerko May 6 '11 at 7:35
1  
about second question, looks like script just add vga=0xXYZW parameter to /etc/default/grub . It should work if it worked for you on 10.10. Grub config stays same, only thing that could changed is graphic driver –  Denwerko May 6 '11 at 8:05
add comment

3 Answers 3

I got corrupt boot and terminal screens (white blocks with black lines) when installing 11.04 with an nvidia graphics card, though X server itself was okay. I fixed the problem by apt-get install startupmanager, running startupmanager and increasing the boot screen resolution and colour depth.

share|improve this answer
add comment

Abou script: yes, I have just used for Kubuntu. About your problem, I think, you have missed some step, or made typo in cfg file. Recheck it all. The resolution you choose must be available via VBE. Enter GRUB console while booting and command "vbeinfo" to get a list.

share|improve this answer
add comment

Run in Terminal

1.sudo apt-get install v86d

2.gksu gedit /etc/default/grub

3.Replace Line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

New Line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1920x1080-24,mtrr=3,scroll=ywrap"

5.Replace Line:#GRUB_GFXMODE=640x480

New Line:#GRUB_GFXMODE=1920x1080 6.Save & Close

7.gksu gedit /etc/initramfs-tools/modules

8.Add Line: uvesafb mode_option=1920x1080-24 mtrr=3 scroll=ywrap Save & Close

9.sudo update-grub2

10.sudo update-initramfs -u

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.