Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Brief summary:
I installed Nvidia proprietary drivers and at boot I see the splash screen and then it drops to the command line login screen.

Details: I am running Kubuntu 13.10 and wanted to install Nvidias proprietary drivers. I added ppa:xorg-edgers and installed nvidia 331 drivers. After a reboot KDE is not starting. The splash screen is shown and then it drops to the command line login prompt.

Things I tried:

1) Uninstall ppa using ppa-purge and reboot
-> no change

2) Uninstall nvidia drivers using apt-get purge nvidia*, checking that dkms did not list any nvidia modules, then reinstall everything
cf. http://askubuntu.com/a/225763/236251
-> no change

3) Blacklist nvidia drivers and use nouveau drivers
-> no change (although I am not entirely sure that I did everything correctly here)

4) Use jockey-text (sudo jockey-text -l and sudo jockey-text -e ..) to install or disable the nvidia divers

5) Reinstall ppa:xorg-edgers and reinstall nvidia 331
-> no change

Question:
What I am looking for is ideally to get the nvidia drivers up and running but simply reverting my changes would also make me very happy! Any help is highly appreciated.

System details: cat /proc/version

Linux version 3.11.0-15-generic (buildd@batsu) (gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu8) ) #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013

lspci | grep VGA

03:00.0 VGA compatible controller: NVIDIA Corporation G96GL [Quadro FX 580] (rev a1)

Here is the relevant section in Xorg.0.log

[ 18.736] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[ 18.736] (II) "glx" will be loaded by default.
[ 18.736] (WW) "xmir" is not to be loaded by default. Skipping.
[ 18.736] (II) LoadModule: "glx"
[ 18.806] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[ 20.048] (II) Module glx: vendor="NVIDIA Corporation"
[ 20.048] compiled for 4.0.2, module version = 1.0.0
[ 20.048] Module class: X.Org Server Extension
[ 20.048] (II) NVIDIA GLX Module 304.117 Tue Nov 26 21:45:09 PST 2013
[ 20.048] Loading extension GLX
[ 20.048] (II) LoadModule: "nvidia"
[ 20.048] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[ 20.239] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 20.239] compiled for 4.0.2, module version = 1.0.0
[ 20.239] Module class: X.Org Video Driver
[ 20.250] (II) NVIDIA dlloader X Driver 304.117 Tue Nov 26 21:27:08 PST 2013
[ 20.250] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 20.251] (++) using VT number 7

[ 20.253] (II) Loading sub module "fb"
[ 20.253] (II) LoadModule: "fb"
[ 20.280] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 20.293] (II) Module fb: vendor="X.Org Foundation"
[ 20.293] compiled for 1.14.5, module version = 1.0.0
[ 20.293] ABI class: X.Org ANSI C Emulation, version 0.4
[ 20.293] (II) Loading sub module "wfb"
[ 20.293] (II) LoadModule: "wfb"
[ 20.294] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 20.300] (II) Module wfb: vendor="X.Org Foundation"
[ 20.300] compiled for 1.14.5, module version = 1.0.0
[ 20.300] ABI class: X.Org ANSI C Emulation, version 0.4
[ 20.300] (II) Loading sub module "ramdac"
[ 20.300] (II) LoadModule: "ramdac"
[ 20.300] (II) Module "ramdac" already built-in
[ 20.303] (* ) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 20.303] (==) NVIDIA(0): RGB weight 888
[ 20.303] (==) NVIDIA(0): Default visual is TrueColor
[ 20.303] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 20.303] (
*) NVIDIA(0): Enabling 2D acceleration
[ 20.324] (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module. Please see the
[ 20.324] (EE) NVIDIA(0): system's kernel log for additional error messages and
[ 20.324] (EE) NVIDIA(0): consult the NVIDIA README for details.
[ 20.324] (EE) NVIDIA(0): * * * Aborting * * *
[ 20.324] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 20.324] (II) UnloadModule: "nvidia"

[ 20.324] (II) UnloadSubModule: "wfb"
[ 20.324] (II) UnloadSubModule: "fb"
[ 20.324] (EE) Screen(s) found, but none have a usable configuration.
[ 20.324] (EE)
Fatal server error:
[ 20.324] (EE) no screens found(EE)
[ 20.324] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 20.324] (EE) Please also check the log file at "/var/log/Xorg.0.log" for >additional information.
[ 20.324] (EE)
[ 20.325] (EE) Server terminated with error (1). Closing log file.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.