Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This working and not working happens to me often, and I dont know, why this is happening. I am frustrated trying all the related threads but it couldnt solve my problem. This wired lan connection is working fine on Windows 7.

I have made all pssible edits of /etc/network/interfaces , but no success Please help. I dont know what all this etho, lo , stuff means Why is this problem on Ubuntu 12.04 but not on Windows?

currently, my /etc/network/interfaces has

auto lo
iface lo inet loopback

On running ifconfig, it gives :

eth0      Link encap:Ethernet  HWaddr 14:fe:b5:c5:a2:0d  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:47 

eth0:avahi Link encap:Ethernet  HWaddr 14:fe:b5:c5:a2:0d  
          inet addr:169.254.8.129  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:47 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2022 (2.0 KB)  TX bytes:2022 (2.0 KB)

pan1      Link encap:Ethernet  HWaddr 46:f9:3a:a8:a6:ca  
          inet addr:10.63.169.1  Bcast:10.63.169.255  Mask:255.255.255.0
          inet6 addr: fe80::44f9:3aff:fea8:a6ca/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:100 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:15665 (15.6 KB)

wlan0     Link encap:Ethernet  HWaddr 88:53:2e:10:f8:24  
          inet addr:10.132.238.81  Bcast:10.132.255.255  Mask:255.255.0.0
          inet6 addr: fe80::8a53:2eff:fe10:f824/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:14890 errors:0 dropped:0 overruns:0 frame:0
          TX packets:671 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1886759 (1.8 MB)  TX bytes:207660 (207.6 KB)
share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Ok..I realized what the problem is... it is because of a loose connection in my lan port (a little loose lan wire), Ubuntu 12.04 couldn't recognize my lan wire, but surprisingly Windoes 7 recognizes without any problem... I dont understand this , though. When I replaced my lan wire, with a nice tight one, Ubuntu recognized it instantly...

Somebody can please throw a light on this.

Also , I want to answer about a kind of solution for 'wifi disabled by hardware switch on Dell xps' but i couldnt as i my reputation is low. So, I am asnwering it here.

There are many opinions in the forums, like:
you can get your wifi enabled on Dell xps (where one doesnt have a separate hardware switch)
1) Fn + F2
2) Alt + Fn + F2
3) changing ssomething in the /etc/network/interfaces file

I have tried these all, but these wont work all the time...

but for me, what works all the time on my Dell xps L502x is:
CLICK ON THE STAR BUTTON ON THE RIGHT TOP CORNER ON UR DESKTOP AND CLICK on 'SUSPEND'
then, IMMEDIATELY, WAKE UP FROM THE 'SUSPEND' MODE
and , then DO 'Fn + F2' one or two times...
Then wifi gets enabled on my laptop without any fuss whatsoever
I accidentally figured this out. had I figured it years ago, I would have saved myself of lot of torture about wifi connectivity problems

Hope this helps many other people like me, who was frustrated for about 1 and half years with this problem, but beleive me, I absolutely don't have a problem now

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.