Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After successful samba sharing already few days ago I have the same thing today yet I have received the following error:

'net usershare' returned error 255: net usershare add: cannot convert name "Everyone" to a SID. 
The connection was refused. Maybe smbd is not running.

When trying to start/restart samba service I get the following

$ sudo service samba status
 * nmbd is running
 * smbd is not running
$ sudo service samba start
$ sudo service samba restart
$ sudo service samba status
 * nmbd is running
 * smbd is not running

My /var/log/samba/smbd.log

[2014/01/15 16:21:46,  0] smbd/server.c:1072(main)
  smbd version 3.6.18 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2011
[2014/01/15 16:21:46.426302,  0] smbd/server.c:1128(main)
  standard input is not a socket, assuming -D option
[2014/01/15 16:21:46.428538,  0] auth/auth_util.c:708(get_guest_info3)
  SamInfo3_for_guest: Unable to locate guest account [guest]!
[2014/01/15 16:21:46.428578,  0] smbd/server.c:1251(main)
  ERROR: failed to setup guest info.

My /etc/samba/smb.conf

$ grep -E "^[^#;].*" /etc/samba/smb.conf
[global]
   workgroup = WORKGROUP
   server string = %h server (Samba, Ubuntu)
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
        usershare allow guests = yes
        username map = /etc/samba/smbusers
        security = user
        guest ok = yes
        ; guest account = nobody
  usershare max shares = 100
  usershare owner only = False
share|improve this question

2 Answers 2

This error is also present in normal user sessions. I have it on 2 machines with fresh installs of Ubuntu 14.04.

I have filed a bug report https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1299186

Please mark the bug as "also affecting me" if you experience the same problems as apport will not trigger automatically when this bug occurs.

share|improve this answer
up vote 1 down vote accepted

The problem was with username. I have uncommented this line:

guest account = nobody

having nobody user in my system and now it works fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.