Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c) and when I plug a vga or HDMI cable I can't see the second monitor and the I only see a mess main monitor, like this screenshot http://ubuntuone.com/p/rBo/.

share|improve this question
    
The screenshot link does not work: "Could not locate object". I suggest imgur.com –  Marius Gedminas Jul 14 '11 at 9:49
add comment

1 Answer 1

I often use a second monitor with my laptop, which has an Intel GM965 video card. Usually it works fine, sometimes it fails in one of the two ways:

  • Both screens freeze and nothing happens, I can't interact with the system. Forcefully killing the GUI session with Alt+SysRq+K helps.

  • One of the screens is fully or partially obscured by a black rectangle; I can see the mouse cursor, but I cannot see my desktop or any windows. Restarting Compiz or Unity fixes this; I usually do Alt+F2 unity Enter.

VGA hotplug detection works for me in 11.04 (it didn't in 10.10 or earlier versions), so it's enough for me to plug in a monitor and wait about a second for it to be autoconfigured. If this doesn't happen for you, or if Ubuntu's chosen autoconfiguration (cloned display versus extended desktop) is not to your liking, you can run gnome-display-properties ("Monitors" in the GNOME Control Center) and specify what configuration you'd like to have.

I don't have a HDMI connection on my laptop, so I cannot say from personal experience if there are any bugs affecting HDMI.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.