Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Skype has been working fine for a fair while, but has (in the last week or so) stopped making notification sounds. Normal audio for calls is fine, but the ringtone and other alerts are now not making any noise at all.

The cause appears to be that the wav files are all missing.

Skype Hates Me

I've not deleted them - at least, not knowingly - and not made any changes within Skype. I ran an update and upgrade to my whole system recently, so the cause is likely there, but I have no idea where to start looking to sort this out.

Is it just going to be simplest to download the sound files and set them all manually, or is this a known issue with another fix?

Edit: Forgot to say - the sound files are normally (I believe) in /usr/share/skype/sounds, but I don't have a /usr/share/skype folder at all.

share|improve this question
    
Did you try to reset settings? –  Danatela Jan 15 at 9:09
    
Yes, no luck unfortunately. –  Dave Child Jan 15 at 9:14
    
How can Skype even work in the first place, if there are no files in '/use/share' to run it from? Perhaps they are now in '/opt' or something? –  Wilf Jan 15 at 10:31
    
Try searching for them across your filesystem with locate *.wav –  K7AAY Jan 15 at 11:52
    
wilf: No idea. Good question. –  Dave Child Jan 15 at 11:57
show 1 more comment

2 Answers 2

up vote 3 down vote accepted

Since /usr/share/skype is gone, and this is a systemwide folder created by installing Skype, that suggests reinstalling Skype might work. (Note that this will likely work even though resetting your user-specific Skype settings did not, as resetting your personal Skype settings doesn't affect anything in /usr.)

Assuming you installed Skype from the partner repository (for example, in the Software Center), running these commands in a Terminal (Ctrl+Alt+T) will reinstall it:

sudo apt-get update
sudo apt-get --purge --reinstall install skype skype-bin

[I've edited this to include purging and reinstalling the skype-bin support package as well, which may be necessary, as described in minerz029's excellent answer.]

Assuming all that's wrong is the missing /usr/share/skype folder, a weaker form of reinstalling (which doesn't clear out systemwide configuration files) can be achieved by leaving out the --purge flag or by going into the Software Center, removing Skype, and installing it again.

If you installed Skype in some other way, you should tell us how; depending on how you installed it, it may or may not be expected for a /usr/share/skype folder to exist, and the inaccessibility of those files could be a file ownership/permissions problem.

share|improve this answer
    
I'm happy to reinstall (and would hope that would sort it out) but I'm also quite curious to try to figure out why they've suddenly vanished. It sounds like that's not likely to be something I can work out though. –  Dave Child Jan 15 at 10:19
    
@DaveChild After fixing this, you could downgrade skype and skype-bin to their previous versions. (You might have the packages for the older versions in /var/cache/apt/archives.) Then you can upgrade again and see if the files disappear again as a consequence. If they do, then you've almost certainly found a bug (even if they don't disappear for some other users doing the same upgrade on different Ubuntu installations). You could then report it as one (against the skype-bin package, most likely), which might lead to an explanation. –  Eliah Kagan Jan 15 at 10:45
    
I removed and reinstalled Skype and all is well now. I tried downgrading but it just broke skype entirely. Perhaps this is destined to forever remain a mystery ... –  Dave Child Jan 16 at 10:16
add comment

The .wav files are from the skype-bin package.

You may try to reinstall that package:

sudo apt-get install --reinstall skype-bin

I have the .wav files at the following locations, Ubuntu 13.04:

/usr/share/skype/sounds/CallBusy.wav
/usr/share/skype/sounds/CallConnecting.wav
/usr/share/skype/sounds/CallFailed.wav
/usr/share/skype/sounds/CallHangup.wav
/usr/share/skype/sounds/CallHold.wav
/usr/share/skype/sounds/CallRemoteHangup.wav
/usr/share/skype/sounds/CallResume.wav
/usr/share/skype/sounds/CallRingingIn.wav
/usr/share/skype/sounds/CallRingingOut.wav
/usr/share/skype/sounds/ChatIncoming.wav
/usr/share/skype/sounds/ChatIncomingInitial.wav
/usr/share/skype/sounds/ChatOutgoing.wav
/usr/share/skype/sounds/ContactAdded.wav
/usr/share/skype/sounds/ContactAuthRequest.wav
/usr/share/skype/sounds/ContactOffline.wav
/usr/share/skype/sounds/ContactOnline.wav
/usr/share/skype/sounds/SkypeLogin.wav
/usr/share/skype/sounds/SkypeLogout.wav
/usr/share/skype/sounds/TransferComplete.wav
/usr/share/skype/sounds/TransferFailed.wav
/usr/share/skype/sounds/TransferRequest.wav
/usr/share/skype/sounds/VoicemailReceived.wav
share|improve this answer
    
Thanks for your answer. Reinstalling sorted the problem out, but as Eliah suggested that first, I've accepted their answer. If there was a way to share the credit, I would, but alas there isn't. Thanks for answering though, much appreciated. –  Dave Child Jan 16 at 10:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.