Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I launch a program, say firefox, it starts maximized, how can I keep this from happening. Its so ridiculous that they have this as the default.

share|improve this question
add comment

5 Answers

Just to flag up that the auto-maximize percentage is now configurable in 11.10 in ccsm (the CompizConfig Settings Manager). Idiotically, it's hard-coded in 11.04 despite there having been issues with what the percentage should be early on (originally it was 60%, people complained, and the answer was to change the value rather than do the obvious thing of making it configurable as this is clearly going to be user- and system-specific). I haven't found a convenient way to back-port the fix to 11.04. (You can always upgrade, of course.)

But on 11.10:

  • Install ccsm if you don't already have it (bizarrely, it's not installed by default)
  • Run it
  • Go to Desktop
  • Click Ubuntu Unity Plugin
  • Go to the Experimental tab and you should see this: enter image description here Set the Auto-maximize value to 100% to completely disable it, or just to a higher percentage if you like the behavior but the default 75% is the wrong value for you.

Sources:

share|improve this answer
add comment

To fix this with Unity 2d, do this on the command line:

gconftool -s /apps/metacity/general/auto_maximize_windows -t bool false

Or, launch gconf-editor and change that key to false.

This annoyed the heck out of me, too. :( The fix is different for unity 2d than for 3d unity,

share|improve this answer
    
Oh man! ldrn you found a solution that works perfectly! This whole week you’re officially my hero. I could hug you right now. –  Mood Jun 20 '11 at 6:32
add comment

Found this in this thread, tested it, and it seems to be true.

You need to open the app, resize the window so it is below 75% of the screen size, then close the app. By default any window over 75% will be maxed when opening. - mc4man

Also, according to the same thread, this behavior can only be changed by editing unity source and recompiling. Not the answer we'd like to hear...

share|improve this answer
    
Thanks! That sure is it. I agree it should not require a recoding.. I did enable resize windows plugin in compiz settings manager and that helped. However at least its a start! Thanks for the reply! –  Scott May 6 '11 at 11:21
    
the resize info plugin sure can help us by showing the size that the window is taking when we resize it. I hope they put that configurable soon (with gconf-editor, for example) –  bluefoot May 10 '11 at 0:02
    
@bluefoot: They have in 11.10, in ccsm, details. –  T.J. Crowder Oct 23 '11 at 10:56
add comment

Unity was designed to auto-maximize windows if they take up a certain amount of screen space. To my knowledge not every single window does this, but most of them will. Currently there is no way to disable this in Unity 2D, but you can disable grid in ccsm, or you can edit the values to your liking, to avoid this maximization.

enter image description here

Basically, you can disable the top edge (set it to none) to avoid windows auto maximizing.

share|improve this answer
1  
Maximus isn’t installed. I’m running 11.04 with unity 2D. The auto-maximizing seems to be a default feature of unity. My other computer uses 11.04 with Compiz Unity displays the same behavior. Basically when a window covers a certain amount of the desktop—lets say 80%—the window will jump to maximized every time the window gets re-opened. Even when alt+tab is used. –  Mood May 11 '11 at 9:37
    
@Mood: Oh... I'll update my answer. –  RolandiXor May 11 '11 at 15:43
    
Sometimes when a window is maximized and I use alt+tab to switch windows it doesn't give focus to my selected window. It will show Unity and the apps icon will shake. I have to press the icon to give it focus. I’ll give classic mode a try. Shame because I like Unity. The auto-maximizing and the slow animation when I press Super are the only two real issues I have with it. –  Mood May 13 '11 at 13:56
    
Who ever downvoted this... leave a comment when you downvote instead of downvoting and running. It's silly and unhelpful (yes, you give yourself away as the vote and it's not anonymous anymore but at least I know why you downvoted so I can improve. Otherwise it's just infuriating when you downvote a perfectly good answer). This answer might not be needed in 11.10, but 11.04 users still need it - if that was the reason. –  RolandiXor Nov 18 '11 at 19:38
add comment

Install "Advanced Desktop Effect Settings" (ccsm) through the software center and launch it.

Scroll down to "Window Management" and deselect "Snapping Windows" and "Grid". This will disable snapping to the edges of the screen and maximize when you reach the corners.

Further you can decide whether to start windows centered, smart-positioned or if they should always be maximized etc. in "Place Windows" which is also under "Window Management"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.