Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off, it might be useful to explain that my local network setup is:

[Internet] <---> [192.168.1.1] <---> [10.10.10.1] <---> [Computer]

so, the router at 10.10.10.1 is the computer's gateway and router 192.168.1.1 handles DNS requests.

~~~~~

I installed Ubuntu 12.04 server on the computer in question, but I can't seem to get the ethernet connection working properly. Here's the info that I would think would be useful:

user@SAMserver1:~$ lspci | grep Eth
00:03.0 Ethernet controller: Digital Equipment Coporation DECchip 21140 [FasterNet] (rev 22)

~~~~~

user@SAMserver1:~$ ifconfig eth0
eth0     Link encap:Ethernet HWaddr 00:00:65:19:1f:e3
         inet addr:10.10.10.2 Bcast:10.10.10.15 Mask:255.255.255.240
         UP BROADCAST MULTICAST MTU:1500 Metric:1
         RX packets:0 ettors:0 dropped:0 overruns:0 frame:0
         TX packets:0 errors:3 dropped:0 overruns:0 carrier:3
         collisions:0 txqueuelen:1000
         RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

~~~~~

user@SAMserver1:~$ cat /etc/network/interfaces
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 10.10.10.2
        netmask 255.255.255.240
        gateway 10.10.10.1
        dns-search 192.168.1.1
        dns-nameservers 192.168.1.1

~~~~~

user@SAMserver1:~$ route
Kernel IP routing table
Destination     Gateway        Genmask         Flags Metric  Ref   Use  Iface
default         10.10.10.1     0.0.0.0         UG    100     0       0  eth0
10.10.10.0      *              255.255.255.240 U     0       0       0  eth0

~~~~~

user@SAMserver1:~$ ping -c 1 10.10.10.1
PING 10.10.10.1 (10.10.10.1) 56(84) bytes of data.
from 10.10.10.2 icmp_seq=1 Destination Host Unreachable

--- 10.10.10.1 ping statistics ---
1 packet transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

~~~~~

user@SAMserver1:~$ ping -c 1 www.google.com
ping: unknown host www.google.com

~~~~~

Any advice would be greatly appreciated, and let me know if there's any useful info that I left out.

PS: I did make sure that address 10.10.10.2 was reserved on the router for the server's MAC address

PPS: Trimmed output of "lspci -vvv"

00:03.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 [FasterNet] (rev 22)
    Subsystem: Cogent Data Technologies, Inc. Device 2500
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 66 (5000ns min, 10000ns max), Cache Line Size: 32 bytes
    Interrupt: pin A routed to IRQ 3
    Region 0: I/O ports at 1000 [size=128]
    Region 1: Memory at 44000000 (32-bit, non-prefetchable) [size=128]
    [virtual] Expansion ROM at 18000000 [disabled] [size=256K]
    Kernel driver in use: tulip
    Kernel modules: tulip
share|improve this question
add comment

2 Answers 2

You need setup the LAN network first before reaching to the DNS Server in another network.

You got errors from ifconfig, there could be a number of things: hardware: faulty cable, malfunction connector. s/w setting: mismatch duplex, wrong kernel driver for your NIC etc.

When you rule out those things, try have a consistent netmask settings too, just a good practice. as I see three different netmask from your output: 255.255.255.240 from 'ifconfig', 255.255.255.252 in /etc/network/interfaces, 255.255.255.242 from 'route'.

share|improve this answer
    
Whoops, the mis-mashed subnets were a typo (I had to type all that info manually). It's fixed now. –  SamWN Jan 15 at 6:28
    
If by "setup the LAN" you mean configure the routers: they're properly configured. I'm able to connect to the internet through my LAN with other computers and I know that the issue isn't there. I know that the Ethernet cable itself works fine, but I can't say for sure that the card or some other components are working flawlessly, but I tried two different NICs and had the same problems. I'm pretty sure that it's a software configuration issue. –  SamWN Jan 15 at 6:37
    
:) you can do a copy & paste. type all takes quite long. do you have more logs (e.g. syslog)? regarding the driver being used by NIC, use 'lspci -vvv' to check. if your NIC is quite new, you probably need to use the latest kernel like 3.8.0 or 3.11.0. –  timl Jan 15 at 7:42
    
I appended the output of lspci -vvv to the original post (and I found that the 'script' command is truly one's friend when limited to the terminal). BTW, the NIC cards are the better portion of a decade old, so I should think the drivers would be included. –  SamWN Jan 15 at 8:46
    
The version of Ubuntu I'm using doesn't seem to come with syslog preinstalled. –  SamWN Jan 15 at 8:49
show 2 more comments
up vote 0 down vote accepted

It's not so much of "solution," but since I originally installed Ubuntu without the PCI ethernet card, I gave reinstallation with the card in place a try and that seemed to do the trick.

share|improve this answer
    
IMO, this is mostly related to the driver. but glad it's working now. personally I rarely do a reinstallation with Linux unless I did 'rm -rf /' :) –  timl Jan 20 at 4:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.