Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to Natty and the 2.6.38-8 kernel I could no longer obtain the 1920x1080 resolution available in Maverick with 2.6.35-22. In fact the boot occasionally hung. However, after selecting the remaining 2.6.35-22 kernel, the high resolution was available.

I then made the mistake of completely reinstalling, but could never get the higher resolutions with 2.6.38-8, no matter what I did. e.g. trying the nvidia proprietary driver, creating an xorg.conf. Even from the command line using

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

xrandr --addmode DVI-I-1 1920x1080_60.00

xrandr --output DVI-I-1 --mode 1920x1080_60.00

all I would get would be a blank screen and the monitor reporting no input. (Low resolutions displayed fine with xrandr.) I could actually add the 1920x1080 to the already existing probe-reported resolutions in the pool of available resolutions, but choosing it would give the blank screen. In the end I installed the 2.6.35-22 kernel again. The high resolution is back.

For a while there, staying up all night and trying many things, I thought that a new video board or monitor might be needed, but deep down, I knew that they were both OK.

My question is - "Is this some bug involving the latest kernel, that will go away, or if this persists in future kernels, is there a way to make sure that I can keep my native resolution?"

share|improve this question

closed as too localized by jrg, Marco Ceppi Dec 27 '11 at 21:53

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
+1 for sure, I'm also 1920x1080 and I have been struggling with askubuntu.com/questions/12578/… - Still no solution! –  Aleksandr Levchuk May 6 '11 at 2:38
    
1920x1080 was automatically selected for my Acer G215H with an Nvidia GeForce 210 card. –  fragos May 6 '11 at 3:18
    
I have no problem too with GT240 and my new 1920x1080 monitor –  Extender May 6 '11 at 3:21
    
So it is possible that the latest version of nouveau does not work with a particular video card (nVidia GeForce4 MX 440 AGP 8x), but the previous versions did, and if I want to use the latest kernel I have to buy another card, even though this one is otherwise fine for my purposes? –  time-wastrel May 6 '11 at 23:02
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Dec 27 '11 at 15:23

1 Answer 1

No guarantees, but you might try installing the latest kernel from the Kernel PPA; I have an Intel video system, but that fixed several problems I had. Check out: https://launchpad.net/~kernel-ppa/+archive/ppa

share|improve this answer
    
Thank for the suggestion Bryan. I didn't know where to find new, unreleased, kernels. Now I'll give them a try and keep trying until one of them works. I feel better about doing that than locking myself into the 2.6.35-22 kernel. –  time-wastrel May 20 '11 at 23:25
    
It may also be helpful to know that if you need to boot an older kernel, hold shift as you boot and the Grub menu will pause so you can select it. –  Bryan Agee May 24 '11 at 1:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.