Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I accidentally disabled my monitors, so when I log in I land on a blank, back-lit screen. I can open terminals with Ctrl+Alt+F#, so how do I enable the monitor from terminal?

I tried xrandr, but it can't open display. xset does not work either. I found this question which closely resembles my problem. The answer provides a script to be put in /etc/X11/Xreset.d.

Running it does not solve my problem (though it is likely I don't understand how to use it properly). I think I somehow made the new default to be "disable monitors".

Running Ubuntu Studio 13.10. I do not have nVidia drivers. I can't find an xorg.conf file to remove. Thankful for any and all input!

Edit: Output of command xrandr -d :0

Screen 0: minimum 320x200, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected 1366x768+-32768+-32768 (normal left inverted right x axis y axis) 344mm x 192mm
    1366x768    60.0*
    1360x768    59.8    60.0
    1024x768    60.0
    800x600     60.3    56.2
    640x480     59.9
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Still being a CLI beginner I fail to understand from man xrandr how to switch on (there is an off option) or enable displays. Output of xrandr --auto is Can't open display

Edit 2: Output of xrandr -d :0 --auto

Configure crtc 0 failed

Maybe I just have to reinstall X11?

Edit 3: Outputs of suggested commands / which xset commands I tried:

xrandr -d :0 output LVDS1 --auto

    configure crtc 0 failed

xset q and xset dpms force on both return

    unable to open display ''''

No difference for sudo commands.

Edit 4: More futile attempts and the potential discovery of a security issue

  • 4.1 I've tried to reinstall Xorg and X11, then I ran sudo apt-get install --reinstall xserver* which failed with this output:

    (many versions of this:) Note, selecting 'xserver-xorg-something' for regex 'xserver*' (next:) Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
    xserver-xorg-input-mtrack : Conflicts: xserver-xorg-input-multitouch
    but 1.0~rc2+git20110312-2build4 is to be installed
    E: Unable to correct problems, you have held broken packages.
  • 4.2 Next I logged in as guest and logged in as myself through tty Ctrl+Alt+F# and ran the same xrand commands as above (OP and edits 1-3), with the same output as far as I can see.

  • 4.3 Then I created a new_user with full admin rights and repeated 4.2 via tty.

  • 4.4 SECURITY ISSUE? No, just a need of awareness. Not related to this subject, details at launchpad

It begins looking like a system reinstall is necessary :-(

share|improve this question
Try xrandr from the Ctrl-Alt-F1 virtual terminal again, but this time add an explicit display argument e.g. xrandr -d :0 – steeldriver Jan 15 '14 at 1:10
xrandr -d :0 --auto ? – falconer Jan 15 '14 at 19:25
What xset commands did you try? – Seth Jan 15 '14 at 21:07
You need to specify an output device for the --auto directive e.g. xrandr -d :0 --output LVDS1 --auto – steeldriver Jan 16 '14 at 0:18
For xset, see edit #3 – Al F Jan 18 '14 at 9:45
up vote 7 down vote accepted
  1. Figure out that the offending settings are stored in a file called displays.xml.

    I won't detail here how I guessed it, though the comment about deleting monitors.xml proved helpful. It also involved manual comparing of several .config subdirectories.

    Of course, what I should have done was ask my search engine "where does xubuntu store display settings" and find this thread at ubuntuforums...

  2. Log in to your blank display and use CTRL+ALT+F# to enter command line.

  3. sudo find . -type f -name "*displays*"

  4. mv ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml ~/.config/xfce4/xfconf/xfce-perchannel-xml/displays.xml.bak

  5. sudo reboot

I hope this quest may help somebody.

share|improve this answer
This doesn't answer how to get around the xrandr from VT issue, does it? – Pavel Šimerda Dec 15 '14 at 20:45

You should be able to open (and set properties for) a display via the virtual terminal console provided you know the display number for the running X session. That's usually :0 for the primary physical display but that's not always the case. For example, to query display :0

xrandr -d :0 -q

To re-enable a display that's been turned off, it's usually sufficient to use the --auto e.g. to turn the LVDS1 output device on display :0 back on

xrandr -d :0 --output LVDS1 --auto 
share|improve this answer
Output of this command is the same as in edit #2 in my question. See edit #3 – Al F Jan 18 '14 at 9:44
Perhaps we should take a step back - how exactly did you "accidentally disable" your monitors? – steeldriver Jan 18 '14 at 11:45
I had connected a projector. When finished watching I opened display settings, chose the projector entry and clicked "do not use this" (don't remember exact wording). I'm not sure if I accidentally clicked on both, anyway my screen went blank. Can't remember for sure now if I used tty login to reboot (I think I did) or if I did a hard reboot by power button. – Al F Jan 18 '14 at 15:12
Have you tried moving or renaming your ~/.config/monitors.xml file (e.g. mv ~/.config/monitors.xml ~/.config/monitors.xml.bak)? BTW does logging into to a different account or guest account work? – steeldriver Jan 18 '14 at 15:18
I don't find a ~/.config/monitors.xml file on my system. – Al F Jan 18 '14 at 15:20

Try this:

xrandr --output "nameYourVGA" --mode "yourResolution"

For example:

xrandr --output VGA1 --mode 1366x768

See if that works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.