Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After 10 installations trials and dozens of thread read I figured I would need some help.

I just built a mining rig (for litecoin) with these:

1 ASrock 970 Extreme 4
4 Gb Ram
1 Processor AMD Sempron 2,8 GHz
3 Gigabyte Radeon R9 290
1 Blank 8Gb USB stick
1 Live USB for Xubuntu 13.10

I won't got through all the trials and error before getting to the end of the installation without a bug, so here where I'm stuck at:

My motherboard can't allow install in legacy mode, so I successfully installed xubuntu 13.10 having partitioned the USB stick with

500mb swap
100mb of EFI boot
7,4 Gb for /

So when I reboot, the boot hangs to a black screen (no cursor) just after the BIOS screen.

So I as explained in multiple forums, I reboot on LiveUSB and launch boot-repair. It tells me that it detected a winEFI, would I like to activate ? Of course yes. And boot repair finishes.

Here is the boot info summary.

From here I'm almost convinced it should work. I reboot pressing F2 to enter UEFI. I see in my boot order choices that I have a media called Ubuntu. (Sounds good)
But after saving the changes and exiting I don't see any grub... I press enter just to see what happens and at the moment I press the button I see the grub flashing and disappearing right away. Then PC hangs to black screen (still no cursor).

Great! I should get it to work with nomodeset or radeon.modeset=0. So I try that at the second reboot (this time the grub appeared immediately). And I wait with hope for the black screen to turn into the Xubuntu splash screen...

No luck. So I reboot to try to launch Ubuntu in recovery mode. But the system didn't let me, on this boot and the 3 to 5 I did after that, I couldn't boot anymore. My grub was lost. My computer either hangs on the BIOS splash screen or won't recognized my "Ubuntu" media anymore in the UEFI Boot option. It will now say UEFI - VERBATIM 8GB ...

So what am I supposed to do here? I'm open to any advices.

I'm starting to think, maybe my USB stick is broken? (I once got the problem with a LiveUSB, couldn't pass the GRUB or no workaround worked)
Or is something wrong with my install/boot-repair?

share|improve this question
    
Ok I got my installation working with a new USB stick. but still, I have a weird problem. For example this time again at first I forgot to put radeon.modeset=0. So after grub I got a black screen. Then when I rebooted, I lost my grub and I had to go through boot-repair again. Any idea why I loose my grub just after rebooting a failed launch ? –  Julien Hobeika Jan 15 at 23:39

1 Answer 1

up vote 1 down vote accepted

Some EFIs have amnesia -- they forget their boot settings when rebooting or after being powered off. There can also be problems with another OS (typically Windows) resetting its own boot loader as the default. There are several possible solutions to such problems:

  • A firmware update might fix this problem, so it's worth trying. In fact, I'd try this option first.
  • If you're dual-booting with Windows, then in Windows, open an Administrator Command Prompt window and type bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi. Change the path to the boot loader if you're using something else -- note that if Secure Boot is active, you'll be using shim, which is normally shimx64.efi on Ubuntu.
  • Speaking of Secure Boot, try disabling it -- it can sometimes cause problems even if everything is configured the way it should be.
  • Copy EFI/ubuntu/grubx64.efi to EFI/BOOT/bootx64.efi on the ESP. (The ESP is normally mounted at /boot/efi in Ubuntu.)
  • Back up EFI/Microsoft/Boot/bootmgfw.efi (if present) on the ESP and copy grubx64.efi to that name. bootmgfw.efi is the Windows boot loader, and some buggy EFIs boot it automatically.

Those last two items can be done semi-automatically by Boot Repair, although you may need to check an Advanced option to get them to work.

share|improve this answer
    
My firmware is already up to date. I'm not dual booting with Windows. Secure Boot is already disabled. Could edit your answer with a more detailed way to execute your last 2 advices please? It seems it happens only when I hard reboot too many times after a buggy boot (buggy boot = not booting after grub) –  Julien Hobeika Jan 17 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.