Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get my Asus Xonar STX soundcard to work.

It is recognized in the kernal if i type:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: STX [Xonar STX], device 0: Multichannel [Multichannel]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: STX [Xonar STX], device 1: Digital [Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

I have already tried to disable the onboard sound device, This just means that i have no sound at all.

Another note, I can see the device listed on the alsamixer. It does seem to control the hardware to some extent. It will click the soundcard when i change the Analogue out. (in alsamixer as well as the System Settings -> Sound gui)

I not sure what the next step should be. Perhaps blacklisting the Video card sound device. Any pointers would be greatly appreciated.

share|improve this question
add comment

2 Answers 2

To make the Xonar the first sound card, edit the file /etc/modprobe.d/alsa-base(.conf) and add this line:

options snd slots=snd-virtuoso,snd-hda-intel,snd-hda-intel

(You do not need to disable the on-board device.)

In theory, you could just select the Xonar in the sound configuration, but this would affect only programs that use PulseAudio.

share|improve this answer
    
Thanks. It did in fact put the STX to the top. This turned out to not be the issue. Thanks though. –  Zetrocker Jan 15 at 21:46
add comment
up vote 0 down vote accepted

I eventually took the sledgehammer approach, and reinstalled alsa, and parts of the ubuntu desktop.

Found here

Code:

cat /proc/asound/{version,cards,devices,hwdep,pcm,seq/clients}; sudo rm
/etc/asound.conf; sudo rm -r ~/.pulse ~/.asound* ;sudo rm ~/.pulse-cookie; sudo 
apt-get update; sudo apt-get install aptitude; sudo aptitude install paman gnome-
alsamixer libasound2-plugins padevchooser libsdl1.2debian-pulseaudio; sudo lshw 
-short;ls -lart /dev/snd;  cat /dev/sndstat; lspci -nn; lsusb; sudo which alsactl; 
sudo fuser -v /dev/dsp /dev/snd/* ; dpkg -S bin/slmodemd; dmesg | egrep 
'EMU|probe|emu|ALSA|alsa|ac97|udi|snd|ound|irmware'; sudo /etc/init.d/sl-modem-
daemon status; sudo grep model /etc/modprobe.d/* ; sudo dmidecode|egrep 
'anufact|roduct|erial|elease'; lsmod | egrep 'snd|usb|midi|udio'; pacmd list-sinks; 
aplay -l; sudo alsa force-reload;  ubuntu-support-status ; sudo lshw -C sound

Sound is now working after reboot.

Keep in mind that there more precise methods found in the above troubleshooter. This is not the best first option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.