Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 13.04 alongside Windows 8 (which was factory installed). I have the options to turn off both UEFI and Secure Boot. The insall worked fine and I am able to use both operating systems, my problem is with trying to get into one or the other. If I am in Ubuntu and restart, it brings me to the GRUB menu with the following options:

  • Ubuntu
  • Advanced options for Ubuntu
  • Windows UEFI bootmgfw.efi
  • Windows UEFI recovery bkpbootmgfw.efi
  • Windows Boot UEFI recovery
  • Windows UEFI recovery bootmgfw.efi
  • Windows Boot UEFI recovery sda2
  • Windows Boot Manager (UEFI on /dev/sda3)
  • System setup

If I choose Ubuntu it works fine and Ubuntu loads.

When I want to boot into Windows, I have tried multiple options and all of them either load directly into the OS or they give me the Windows Boot Manager, with one option: Windows 8.1.

This is all fine, but if I am in Windows and then want to go back into Ubuntu, there is a problem. I restart (or shut down) and when it starts back up it brings me directly to the ASCII Windows Boot Manager with the one option of Windows 8.1. There is no way to get to GRUB from here, even after multiple reboots. However I have found somewhat of a workaround: First I restart again and go into bios, change UEFI to Legacy and restart. When it turns back on it says "Operating System Not Found!" so I restart it once again, go to the BIOS again and change it back from Legacy to UEFI. Now when I restart it gives me the GRUB menu. That is quite a process just to go from Windows to Ubuntu and I know there must be something wrong. I've gone through the boot-repair process multiple times and changed the power settings in Windows for shutdown so that it doesn't create an image at shutdown.

Also, is there a way to change the GRUB menu to give me only the two options I want? I don't need or want all 11 of them. I've also seen other people have it set to boot to the windows 8 GUI for the boot options, but I can't seem to figure out how to bypass GRUB and get to that. I've tried using EasyBCD and that didn't seem to do anything. I understand there are quite a few problems with the whole process of dual booting these OS's so if this GUI thing doesn't work out I'll be ok.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Boot managers offer you different systems to boot. UEFI is a boot manager unless you have the 'buggy' UEFI one's where they hard code the UEFI to only boot Windows. Grub is both a boot manager and a boot loader. EasyBCD is a boot manager.

UEFI also uses NVRAM so it remembers previous entries. You probably have to manually houseclean old entries with efibootmgr.

Your entry with bkpbootmgfw.efi is the actual Windows efi file renamed by Boot-Repair for the buggy UEFI. It makes shim have the Windows efi filename so UEFI can boot grub. If you can boot the ubuntu entry in UEFI undo the rename. And undo rename before any Windows updates as it will overwrite file and Boot-Repairs backup may be older version on lead to issues.

Grub2's os-prober also found old BIOS type boot entries, that has been fixed with 13.10, but you may want to turn os-prober off so it does not add incorrect entries.

Remove Duplicate Firmware Objects in BCD and NVRAM

http://technet.microsoft.com/en-us/library/cc749510%28v=ws.10%29.aspx

UEFI NVRAM boot entries are cached in the BCD store BCD has 1:1 mappings for some UEFI global variables Any time {fwbootmgr} is manipulated, NVRAM is automatically updated

Some systems work better to register grub/shim from inside Windows - for those that keep resetting Windows as default

Grub not showing on startup for Windows 8.1 Ubuntu 13.10 Dual boot

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

https://coderwall.com/p/vfyqkg

sudo efibootmgr -v

The "-v" option displays all the entries so you can confirm you're deleting the right one, and then you use the combination of "-b ####" (to specify the entry) and "-B" (to delete it). Examples #5 is delete:

http://linux.dell.com/cgi-bin/gitweb/gitweb.cgi?p=efibootmgr.git;a=blob_plain;f=README;hb=HEAD

http://software.intel.com/en-us/articles/efi-shells-and-scripting/

In /etc/default/grub I added this:

sudo cp -a /boot/grub/grub.cfg /boot/grub/grub.cfg.backup
gksudo gedit /etc/default/grub
GRUB_DISABLE_OS_PROBER=true

You can change back to false or remove entry if your grub gets updated to add correct entries. With your version, you have to use Boot-Repair or manually add correct entries to boot Windows.

If from UEFI you can boot ubuntu entry: To undo & to rename files to their original names, you just need to tick the "Restore EFI backups" option of Boot-Repair.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.