Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason my computer running Ubuntu 12.04 has stopped connecting to the wired network on boot. When I run ifconfig I get:

eth0      Link encap:Ethernet  HWaddr 00:21:5a:2e:1a:e2  
          inet addr:192.168.105.105  Bcast:192.168.105.255  Mask:255.255.255.0
          inet6 addr: fe80::221:5aff:fe2e:1ae2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:95 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:60 (60.0 B)  TX bytes:14432 (14.4 KB)
          Memory:f0180000-f01a0000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:115789 (115.7 KB)  TX bytes:115789 (115.7 KB)

It's only after I run sudo dhclient -v eth0 that it's able to connect (IP is in the range 10.0.0.*). Any ideas on why this is happening?

If it's any help here are the contents of /etc/network/interfaces:

auto lo
iface lo inet loopback
share|improve this question
    
Are you running a server without GUI or are you running a desktop environment on your installation? A desktop installation is powered by NetworkManager for this, while servers are usually configured through /etc/network/interfaces, so for providing an answer, please include that in your question. (edit it) –  gertvdijk Jan 14 at 16:30
    
@gertvdijk, good catch. NetworkManager had a wired connection defined that I made a while ago and forgot about. That was what was wrong. Thanks! –  user157450 Jan 14 at 21:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.