Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is not my original question where they were completely transparent and are just not there. I have reinstalled ccsm, but they are still not there.

I have tried unity --reset which I thought would help but it says that unity is not there. I an ccsm in unity and I couldn't even turn on and off unity. Why is it doing this and how can I stop it? I know the shortcut keys for terminal and ccsm in ubuntu so I can adapt from there and in the GNOME classic side. I have had lots of trouble with Natty and kind of don't like it. I tried to uninstall ccsm for some more hard drive space not knowing that it was so closely attached to the OS. I reinstalled it I think I deleted some crucial part of unity that control the panels. I now need to install unity. I tried install unity which didn't work and I need some command.

share|improve this question
    
We need more detail on what you're doing here and what you want to accomplish. Your description sounds like you were trying to turn unity off in which case it you appeared to have shut it off or something. –  Jorge Castro May 5 '11 at 22:44
    
You have only described what you tried to fix your problem. You need to describe the actual problem in more detail, and anything you remember from before the problem began that might be related. –  Ryan Thompson May 6 '11 at 2:18
    
sudo apt-get install compiz –  Extender May 6 '11 at 3:42
3  
Unity is a compiz plugin, you have to reinstall compiz with the unity plugin. –  omnidan May 6 '11 at 4:59
    
Thank you Daniel I think that is what I was looking for. Sorry for being so vague. –  Sam Mercier May 6 '11 at 15:57
show 3 more comments

1 Answer 1

up vote 0 down vote accepted

Unity Panel depends on having Compiz. The following options for Unity are needed:

  • OpenGL
  • Composite
  • Desktop Wall

You could logout and login again but remember to have compiz and those options activated for Unity Panel.

Since Unity Panel NEEDS Desktop Wall to do the hide/show effect, you can not activate the Cube, that is, the Rotating Cube Effect and the Desktop Cube since they disable the Desktop Wall, hence disabling Unity Panel, hence destroying the world (Of Unity) as we know it. Its horrible!

To go to this options just open Dash with SUPER or ALT+F2 and type Compiz Settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.