Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 10.10 64bit and I am trying to install cx_Oracle for python3. I managed to install Oracle XE itself from a deb, but it is 386 version. When I try to install cx_Oracle through easy_install3 I get:

/usr/bin/ld: cannot find -lclntsh

And before that:

/usr/bin/ld: skipping incompatible /usr/lib/oracle/xe/app/oracle/product/10.2.0/

What I can do to have cx_Oracle installed?

share|improve this question
    
Have you tried this? -> eddymulyono.livejournal.com/76874.html –  Sathya May 6 '11 at 4:34
    
I just tried it, but it didn't help. It says it installed properly, but I can't import it from python3.1. –  gruszczy May 8 '11 at 20:56
    
And yes, I have installed version for python3.1. –  gruszczy May 8 '11 at 20:56
    
I have copied it from /usr/lib/python3.1/site-packages to /usr/lib/python3-1/dist-packages. Now it says: ImportError: libclntsh.so.10.1: cannot open shared object file: No such file or directory. –  gruszczy May 8 '11 at 20:58

1 Answer 1

The cx-oracle easy installer is obviously broken. The best thing to do is to go to the developers/packagers and get them to create a debian package for installation on Debian and Ubuntu distributions. This will allow the package to be installed with the known properties of the system instead of guessing where things should be.

If in doubt, report it: https://help.ubuntu.com/community/ReportingBugs

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.