Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm currently using Win7 64bit. I right clicked "wubi.exe" and chose "run as administrator", then nothing happened. I have "ubuntu-10.04.2-desktop-i386.iso" and "wubi.exe" in the same folder. Thanks.

share|improve this question
    
Please file such things as bugs. It's not a question. Launchpad.net is much better suited to handling these kinds of issues. –  Jo-Erlend Schinstad Sep 12 '11 at 18:05
add comment

5 Answers 5

The instructions to run Wubi are here.

Specifically relating to your question:

You are attempting to install a 32bit version of ubuntu into your 64bit O/S. If this was intentional then

To modify arguments, right-click Wubi.exe and select "Create Shortcut". Then right-click the shortcut, select Properties, and modify the Target line, for example: "C:\Documents and Settings\\Desktop\wubi.exe" --32bit

Otherwise, download the 64bit ubuntu ISO and install via wubi by double clicking the exe.

share|improve this answer
add comment

Just Copy wubi.exe and the iso file to c:\

and it will work fine

share|improve this answer
    
It works for me, I put wubi.exe and the iso in S:\ , nothing happend, but put in C:\ , it works! –  Steely Wing Jan 13 at 14:27
add comment

Make sure you have the right version of wubi.exe. For 10.04.2 you get it from http://release.ubuntu.com/lucid But that doesn't explain why 'nothing happened'. Wubi will ignore the wrong iso and download the right version.

Sometimes you can have problems if you have a different version of python installed. You could go to the %temp% directory and remove all py* files and directories. See if that makes a difference.

While you're in the %temp% directory, check for a log file wubi-10.04.2-rev191.log and post that if it exists.

share|improve this answer
    
Hey, i have same problem, and i do have multiple python installations on my system, deleted anything python releated from %temp%, and i do not see any logs. Also, file starts, but it exits after starting (if i run it from console, file executes and i get next cmd prompt entry) –  GrizzLy May 25 '11 at 17:57
    
When I was running a debuggable version of wubi, I found that I had to copy python23.dll into the current directory before it would work. Python doesn't seem very backwards-compatible so it's possible that if it finds a later runtime - it simply doesn't work (that's what I'd guess is happening). –  bcbc May 28 '11 at 21:03
add comment

I had same problem, fixed it by removing all python instances from PATH and PYTHONPATH.

To do that, just press start, write PATH, and you should have entry saying Edit Environment variables or similar, open it, you can delete PATH and PYTHONPATH there (or just modify them temporarily like i did)

In my situation i used mint4win, but it happens with all(?) wubi based installers.

share|improve this answer
add comment

If I were you I would download the wubi executable from ubuntu website and then try that. For a good internet speed, you are looking at max 60secs. and you're ready to roll. The reason for this - is because if you manage to fire the wubi.exe you currently have, it would still connect and pull the download files from the web. Unless you have a way around it to use the directory files, I personally will go the easy way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.