Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

[Edit: the solution provided by chili555 solved my problem. However, note that I further had to remove the drivers "brcmsmac" and "bcma" from blacklisting in order for them to load at each boot (files "broadcom-sta-common.conf" and "blacklist-brcmsmac.conf", not sure it is needed for both files though...). Hope this won't lead to any conflicts.]

I've just upgraded my ubuntu from 12.04 to 13.10 by successive upgades. My main problem after those is that I have trouble to connect to wireless.

Looking through the net, I saw that many people already met this problem, but neither of the methods i tried to fix it did work:

The main effect of the bcmwl-kernel-source driver re-installation (whatever was by the "Softwares & Updates" desktop menu or by the terminal) was to allow the Broadcom card to be detected. Unfortunately, my laptop is still not able to connect to the wireless networks (like for the question: Can find network but cannot connect to it Ubuntu 13.10)

Therefore, I would greatly appreciate any help about that! Many thanks in advance.

Here some details of my hardware and drivers:

$ lspci | grep -i wireless
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)

$ uname -a
Linux ludo-E6530 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

And the wireless network section of

sudo lshw

       *-network
            description: Wireless interface
            product: BCM4313 802.11bgn Wireless Network Adapter
            vendor: Broadcom Corporation
            physical id: 0
            bus info: pci@0000:03:00.0
            logical name: eth1
            version: 01
            serial: 08:3e:8e:50:1c:ee
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
            configuration: broadcast=yes driver=wl0 driverversion=6.30.223.141 (r415941) latency=0 multicast=yes wireless=IEEE 802.11abg
            resources: irq:17 memory:f7600000-f7603fff
share|improve this question

2 Answers 2

up vote 1 down vote accepted

Let's try the other possibility. With a temporary wired ethernet connection:

sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree
sudo modprobe brcmsmac

It may take a reboot.

share|improve this answer
    
Yeah, that works great! However, note that I had to remove the drivers "brcmsmac" and "bcma" from blacklisting (files "broadcom-sta-common.conf" and "blacklist-brcmsmac.conf", not sure it is needed for both files though...). I'll edit my question to give this precision. Thanks again. –  Ludo Duvaux Jan 14 at 16:38
    
If you purge bcmwl-kernel-source, the wrong driver for 14e4:4727, it is supposed to entirely remove the broadcom-sta-common.conf file. –  chili555 Feb 11 at 14:17
    
Well, I don't know why but it appears that this file wasn't removed by purging...This can be linked to my initial problem but I have no idea why to be honest... –  Ludo Duvaux Feb 11 at 17:41

Don't know if this will help, but i notice you did not install linux hearders.
Install linux headers and then reinstall bcmwl:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source

After that log out and log in again.

share|improve this answer
    
Thanks rat2000, but unfortunately the linux headers were already installed: "linux-headers-generic is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded". I tried to re-install the bcmwl anyway but it still doesn't work :( –  Ludo Duvaux Jan 14 at 14:35

protected by fossfreedom Jan 14 at 12:40

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.