Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to Setup an odbc connection from R to my PostgreSQL database located on a server (package RODBC). When trying to connect the connection failed because I entered a wrong Username in the DSN connection defined in odbc.ini.

So I changed odbc.ini and tried again but then RStudio froze. So I killed the process and tried to start the application again. Unfortunately now RStudio didn't start at all anymore (the app in the launcher blinks but does not open the UI). I already uninstalled the application with

sudo apt-get purge rstudio

and reinstalled it again. I updated and upgraded all packages...but still the same error. Also trying to start the program from terminal typing rstudio does not give any result. So any idea how to debug this and get Rstudio working again?

Edit: when i start rstudio from terminal with

rstudio &

it shows me the ID 7547. Still this ID doesn't appear in the processes list in the system monitor.

share|improve this question
    
ok I got it working again by entering "sudo dpkg-reconfigure locales". don't aks me why...I have no idea. –  Joschi Jan 14 at 17:26
    
Please write up your comment as an answer so others may benefit from your experience. –  Elder Geek Jun 15 at 18:56
    
I can't i have not enough reputation... –  Joschi Jun 24 at 9:56
    
You only need a rep of 1 to answer a question here, 10 to answer protected questions like this one, you have 55. If you'd rather not take the time, let me know and I'll do it, but I'd rather you did so I can upvote it. –  Elder Geek Jun 24 at 12:29
    
i know it's wired...i have no option here to respond the question only to add comments. i get a sign below saying that " protected by fossfreedom♦ Jan 14 at 12:42" etc. Therefore it would be great if you could paste it as an answer! –  Joschi Jun 26 at 12:21

1 Answer 1

Open a terminal.

Enter the command:

sudo dpkg-reconfigure locales

This appears to resolve this problem.

Source: Joschi comment above.

share|improve this answer

protected by fossfreedom Jan 14 at 12:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.