Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on a Dell 15R N5110 laptop with only Ubuntu 12.04.3 LTS installed. The laptop has and IDT High Definition chip 92HD87B1/3. It appears correctly recognised as the codec under HDA Intel PCH.

Basic Setup    *Check EDIT

I have an awful high-frequency interference noise in both my headphones and speakers, but at least when on speakers it's not loud enough to bother me. Using the headphones is almost impossible, though.

I have read around and have tried installing the daily build of the DKMS drivers for Intel HDA - not successful.

I tried modifying /etc/modprobe.d/alsa-base.conf by adding the line options snd-hda-intel model=generic - not successful.

I tried modifying /etc/pulse/default.pa with load-module module-udev-detect tsched=0 instead of load-module module-udev-detect- not successful.

Also, I tried isolating the device that is giving off the noise through alsamixer. The result is the following:

  • I cannot mute nor disable Mic Out/Mic In/Internal Mic/Line In/Digital In (setting the volume to 0 has no effect)
  • I can mute Master/Speakers/Headphones/Beep (muting, even Master, has no effect)
  • I can disable Capture (helped a bit)

Thus, I was able to reduce the noise significantly by disabling Capture. I also tried disabling left or right channel only, but the noise remains strong until I disable both.

My problem is that when I disable Capture, my Internal Mic is muted, which defeats the purpose of having it. After all, I want to be able to Skype/Hangout with people using my headphones and my Internal Mic like any other normal person. When I had Windows installed previously, there was no such problem, meaning it's not a hardware issue. (I don't want to go back to Windows, so that solution is out of the question.)

The way I understand the situation is that Capture is the "service" that gets the input sounds in a mix so they can be recorded/outputted, but it should not be able to send them directly to the output. So the problem is somewhere after that. But I have no idea what is controlling it and how to influence it.

TL;DR: Disabling Capture in alsamixer helps, but doesn't solve the problem.

So what do I do?

EDIT:

The daily drivers have changed the audio setup a bit, but the problem still remains the same.

New Setup

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.