Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background

  • Laptop is a Compaq Presarrio CQ61
  • New 32GB SSD (Crucial V4)
  • I'm a ubuntu n00b (after playing with a Live USB, this is my first attempt at installing)
  • Partion A=16GB for windows, 8GB for ubuntu and 8GB ntfs partition intended for shared files (was following this guide)
  • Installed Windows 7 Home Premium SP from downloaded MSDN
  • Installed Ubuntu* from Linux Live USB made from a 32-bit 12.04 image (I can't remember exactly which)

Booting:

Now when booting I see the boot menu, and the Windows 7 option loads fine. However ubuntu normally hangs with a 'purpleish' screen, but no logo or anything. Booting in the recovery mode gives a "Gave up waiting for root device" error. I tried 'exit' from the initramfs prompt which did not work (i.e. after a delay).

I tried Boot Repair tool run from my Linux Live key with no help, but the Boot Info can be found here (sda is the live key, sdb the SSD)

Found a lot of "Gave up waiting for device" errors online, but the only consistent advice about rootdelay doesn't seem to of helped.

In desperation I tried running Linux 3.2.x via the 'Previous versions' option on GRUB and this works.

Question Can anyone help fix the default boot (Linux 3.8.x?) - or should I just stick with the 'previous version' that seems to work?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.